summaryrefslogtreecommitdiff
path: root/dev-perl/RPC-XML
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/RPC-XML
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/RPC-XML')
-rw-r--r--dev-perl/RPC-XML/Manifest5
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.790.0.ebuild56
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild58
-rw-r--r--dev-perl/RPC-XML/metadata.xml39
4 files changed, 158 insertions, 0 deletions
diff --git a/dev-perl/RPC-XML/Manifest b/dev-perl/RPC-XML/Manifest
new file mode 100644
index 000000000000..e1ce56166894
--- /dev/null
+++ b/dev-perl/RPC-XML/Manifest
@@ -0,0 +1,5 @@
+DIST RPC-XML-0.79.tar.gz 209612 BLAKE2B 8135be3e956083b985a00056c4574ab7412223f554a66fdadea1d10abbf837b6c02464cd212d774ef940c6f1524cbbaf651155abc1c35e1cac96aa01e1a058d7 SHA512 541ee3abf4e44cff68a2b7b7c4f78095e8e4ec479d72b52d300503bc1688f64fd01a0ff3c2cdf8e18573d19af0bae467ac68befe7ad8756e6287ed494a50ce26
+DIST RPC-XML-0.80.tar.gz 211223 BLAKE2B e26ba4f667c227e84362ca8e09d17ee01ef45c25902e7bc433bc4a81facacfc6163fc06ddd20a08399131faf18daa97f0f1a173043147f2d5046424c6e3087d3 SHA512 a91586ea903b3e633f85ca8d9048181a7c3aedcff6788c7ae5fb4971e8552c421c86f30254517c25caa35f1991146dcceb34301bb49002e4ec75a2ee9c195992
+EBUILD RPC-XML-0.790.0.ebuild 1477 BLAKE2B f994b3f611a29e732ffc2275770c9da27453c368e0d4ebc583f02085b07b2b5d3e354a538fa613c7e32aa452cc6a3fbfb79e74def4b509dc340817b4359a8105 SHA512 175f0756fb13fcbf2a49d02d0cb12a4044b59af6ea42c064bc3bde2e41af1a7295377177690ceeb666b88e65963068a90f2c1dffd480187c4484d11683711398
+EBUILD RPC-XML-0.800.0.ebuild 1660 BLAKE2B 028c3eb8f391211bbc6c60a5064fffc6557a5ec05f6a2ff7dac7b41cf0deefa63f1978d3fcb7f4aa7ba7775dc95b71bce0103f9cf6ed51a53c6036bee8026af7 SHA512 9032bc0d981c4b51544e3df08ec2bb1a11686f24c6c5cb71957cb198b1952e862eed1a8955281839ec20a3327705fdcb2c6939af2409c7881a1a5d26fe2b3fbd
+MISC metadata.xml 2132 BLAKE2B d79cf95022d41b771f0fed70a1ac781ea84d7b6624e1e059f5f0f99173acbf86e6acdbaf180f12fbc34c6344ea817e47acf109d1f774dde0abfad403fde17341 SHA512 db4a73a2a59419f3840d86e6306eec5436b51fdb0011e537a61a54247ffd0e72f2570cf49d7831ec0a6f5b5dde3f94761fecece1753bbef8fbd0d199b9ae94f4
diff --git a/dev-perl/RPC-XML/RPC-XML-0.790.0.ebuild b/dev-perl/RPC-XML/RPC-XML-0.790.0.ebuild
new file mode 100644
index 000000000000..6c01e61d3dfb
--- /dev/null
+++ b/dev-perl/RPC-XML/RPC-XML-0.790.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=RJRAY
+MODULE_VERSION=0.79
+inherit perl-module
+
+DESCRIPTION="An implementation of XML-RPC"
+
+SLOT="0"
+LICENSE="|| ( Artistic-2 LGPL-2.1 )"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="test"
+
+SRC_TEST="do"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-0.800.0
+ >=dev-perl/libwww-perl-5.834.0
+ >=virtual/perl-Module-Load-0.240.0
+ >=virtual/perl-Scalar-List-Utils-1.200.0
+ >=dev-perl/XML-LibXML-1.850.0
+ >=dev-perl/XML-Parser-2.310.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+# Dubious test.
+PERL_RM_FILES=(
+ t/60_net_server.t
+)
+
+pkg_postinst() {
+ SETWARN=0
+ has_version '=www-servers/apache-2*' && HAVE_APACHE2=1
+ has_version '>=www-apache/mod_perl-2.0' && HAVE_MP2=2
+
+ [ -n "${HAVE_APACHE2}" ] && SETWARN=1
+ [ -n "${HAVE_MP2}" ] && SETWARN=1
+
+ if [ "${SETWARN}" == "1" ]; then
+ ewarn "Apache2 or mod_perl2 were detected."
+ ewarn ""
+ ewarn "NOTE FROM THE AUTHOR OF RPC-XML"
+ ewarn ""
+ ewarn "At present, this package does not work with Apache2 and the soon-to-be"
+ ewarn "mod_perl2. The changes to the API for location handlers are too drastic to"
+ ewarn "try and support both within the same class (I tried, using the compatibility"
+ ewarn "layer). Also, mp2 does not currently provide support for <Perl> sections, which"
+ ewarn "are the real strength of the Apache::RPC::Server class."
+ fi
+}
diff --git a/dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild b/dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild
new file mode 100644
index 000000000000..8f06c0d73737
--- /dev/null
+++ b/dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJRAY
+DIST_VERSION=0.80
+DIST_EXAMPLES=( "ex/*.xpl" )
+inherit perl-module
+
+DESCRIPTION="An implementation of XML-RPC"
+
+SLOT="0"
+LICENSE="|| ( Artistic-2 LGPL-2.1 )"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-0.800.0
+ >=dev-perl/libwww-perl-5.834.0
+ >=virtual/perl-Module-Load-0.240.0
+ >=virtual/perl-Scalar-List-Utils-1.200.0
+ >=dev-perl/XML-LibXML-1.850.0
+ >=dev-perl/XML-Parser-2.310.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+src_compile() {
+ perl-module_src_compile
+ if use examples; then
+ pushd "${S}/ex" >/dev/null || die "Can't enter ${S}/ex"
+ emake MAKEMETHOD="${S}/blib/script/make_method"
+ popd >/dev/null || die "Can't exit ${S}/ex"
+ fi
+}
+pkg_postinst() {
+ SETWARN=0
+ has_version '=www-servers/apache-2*' && HAVE_APACHE2=1
+ has_version '>=www-apache/mod_perl-2.0' && HAVE_MP2=2
+
+ [ -n "${HAVE_APACHE2}" ] && SETWARN=1
+ [ -n "${HAVE_MP2}" ] && SETWARN=1
+
+ if [ "${SETWARN}" == "1" ]; then
+ ewarn "Apache2 or mod_perl2 were detected."
+ ewarn ""
+ ewarn "NOTE FROM THE AUTHOR OF RPC-XML"
+ ewarn ""
+ ewarn "At present, this package does not work with Apache2 and the soon-to-be"
+ ewarn "mod_perl2. The changes to the API for location handlers are too drastic to"
+ ewarn "try and support both within the same class (I tried, using the compatibility"
+ ewarn "layer). Also, mp2 does not currently provide support for <Perl> sections, which"
+ ewarn "are the real strength of the Apache::RPC::Server class."
+ fi
+}
diff --git a/dev-perl/RPC-XML/metadata.xml b/dev-perl/RPC-XML/metadata.xml
new file mode 100644
index 000000000000..0c13785a5b6b
--- /dev/null
+++ b/dev-perl/RPC-XML/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">RPC-XML</remote-id>
+ <remote-id type="cpan-module">Apache::RPC::Server</remote-id>
+ <remote-id type="cpan-module">Apache::RPC::Status</remote-id>
+ <remote-id type="cpan-module">RPC::XML</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Client</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Function</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Method</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Parser</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Parser::XMLLibXML</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Parser::XMLParser</remote-id>
+ <remote-id type="cpan-module">RPC::XML::ParserFactory</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Procedure</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Server</remote-id>
+ <remote-id type="cpan-module">RPC::XML::array</remote-id>
+ <remote-id type="cpan-module">RPC::XML::base64</remote-id>
+ <remote-id type="cpan-module">RPC::XML::boolean</remote-id>
+ <remote-id type="cpan-module">RPC::XML::datatype</remote-id>
+ <remote-id type="cpan-module">RPC::XML::datetime_iso8601</remote-id>
+ <remote-id type="cpan-module">RPC::XML::double</remote-id>
+ <remote-id type="cpan-module">RPC::XML::fault</remote-id>
+ <remote-id type="cpan-module">RPC::XML::i4</remote-id>
+ <remote-id type="cpan-module">RPC::XML::i8</remote-id>
+ <remote-id type="cpan-module">RPC::XML::int</remote-id>
+ <remote-id type="cpan-module">RPC::XML::nil</remote-id>
+ <remote-id type="cpan-module">RPC::XML::request</remote-id>
+ <remote-id type="cpan-module">RPC::XML::response</remote-id>
+ <remote-id type="cpan-module">RPC::XML::simple_type</remote-id>
+ <remote-id type="cpan-module">RPC::XML::string</remote-id>
+ <remote-id type="cpan-module">RPC::XML::struct</remote-id>
+ </upstream>
+</pkgmetadata>