summaryrefslogtreecommitdiff
path: root/dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild')
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild b/dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild
new file mode 100644
index 000000000000..8f06c0d73737
--- /dev/null
+++ b/dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJRAY
+DIST_VERSION=0.80
+DIST_EXAMPLES=( "ex/*.xpl" )
+inherit perl-module
+
+DESCRIPTION="An implementation of XML-RPC"
+
+SLOT="0"
+LICENSE="|| ( Artistic-2 LGPL-2.1 )"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-0.800.0
+ >=dev-perl/libwww-perl-5.834.0
+ >=virtual/perl-Module-Load-0.240.0
+ >=virtual/perl-Scalar-List-Utils-1.200.0
+ >=dev-perl/XML-LibXML-1.850.0
+ >=dev-perl/XML-Parser-2.310.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+src_compile() {
+ perl-module_src_compile
+ if use examples; then
+ pushd "${S}/ex" >/dev/null || die "Can't enter ${S}/ex"
+ emake MAKEMETHOD="${S}/blib/script/make_method"
+ popd >/dev/null || die "Can't exit ${S}/ex"
+ fi
+}
+pkg_postinst() {
+ SETWARN=0
+ has_version '=www-servers/apache-2*' && HAVE_APACHE2=1
+ has_version '>=www-apache/mod_perl-2.0' && HAVE_MP2=2
+
+ [ -n "${HAVE_APACHE2}" ] && SETWARN=1
+ [ -n "${HAVE_MP2}" ] && SETWARN=1
+
+ if [ "${SETWARN}" == "1" ]; then
+ ewarn "Apache2 or mod_perl2 were detected."
+ ewarn ""
+ ewarn "NOTE FROM THE AUTHOR OF RPC-XML"
+ ewarn ""
+ ewarn "At present, this package does not work with Apache2 and the soon-to-be"
+ ewarn "mod_perl2. The changes to the API for location handlers are too drastic to"
+ ewarn "try and support both within the same class (I tried, using the compatibility"
+ ewarn "layer). Also, mp2 does not currently provide support for <Perl> sections, which"
+ ewarn "are the real strength of the Apache::RPC::Server class."
+ fi
+}