summaryrefslogtreecommitdiff
path: root/dev-perl/Proc-Guard/Proc-Guard-0.70.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Proc-Guard/Proc-Guard-0.70.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Proc-Guard/Proc-Guard-0.70.0.ebuild')
-rw-r--r--dev-perl/Proc-Guard/Proc-Guard-0.70.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Proc-Guard/Proc-Guard-0.70.0.ebuild b/dev-perl/Proc-Guard/Proc-Guard-0.70.0.ebuild
new file mode 100644
index 000000000000..19631b0ca659
--- /dev/null
+++ b/dev-perl/Proc-Guard/Proc-Guard-0.70.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TOKUHIROM
+DIST_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="process runner with RAII pattern"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Accessor-Lite-0.50.0
+ >=virtual/perl-Exporter-5.630.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/File-Which
+ dev-perl/Test-TCP
+ dev-perl/Test-Requires
+ dev-perl/Test-SharedFork
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"