summaryrefslogtreecommitdiff
path: root/dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild')
-rw-r--r--dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild b/dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild
new file mode 100644
index 000000000000..db0029e61b38
--- /dev/null
+++ b/dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.104
+inherit perl-module
+
+DESCRIPTION="File path utility"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc x86 ~amd64-fbsd"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/Unicode-UTF8-0.580.0
+ )
+ virtual/perl-Carp
+ >=virtual/perl-Digest-1.30.0
+ >=virtual/perl-Digest-SHA-5.450.0
+ >=virtual/perl-Exporter-5.570.0
+ >=virtual/perl-File-Path-2.70.0
+ >=virtual/perl-File-Spec-0.860.0
+ >=virtual/perl-File-Temp-0.190.0
+ virtual/perl-if
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ !minimal? (
+ >=virtual/perl-JSON-PP-2.273.0
+ dev-perl/Test-FailWarnings
+ dev-perl/Test-MockRandom
+ )
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"