summaryrefslogtreecommitdiff
path: root/dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild')
-rw-r--r--dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild b/dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild
new file mode 100644
index 000000000000..3a8ae7121aba
--- /dev/null
+++ b/dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=1.014
+inherit perl-module
+
+DESCRIPTION="Iterative, recursive file finder"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Spec
+ >=dev-perl/Number-Compare-0.20.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Text-Glob
+ dev-perl/Try-Tiny
+ virtual/perl-if
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ virtual/perl-Exporter
+ virtual/perl-File-Temp
+ dev-perl/File-pushd
+ dev-perl/Path-Tiny
+ dev-perl/Test-Deep
+ >=dev-perl/Test-Filename-0.30.0
+ >=virtual/perl-Test-Simple-0.920.0
+ virtual/perl-parent
+ )
+"