summaryrefslogtreecommitdiff
path: root/dev-perl/Path-IsDev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Path-IsDev
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Path-IsDev')
-rw-r--r--dev-perl/Path-IsDev/Manifest4
-rw-r--r--dev-perl/Path-IsDev/Path-IsDev-1.1.3.ebuild38
-rw-r--r--dev-perl/Path-IsDev/metadata.xml38
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-perl/Path-IsDev/Manifest b/dev-perl/Path-IsDev/Manifest
new file mode 100644
index 000000000000..85063f4806c7
--- /dev/null
+++ b/dev-perl/Path-IsDev/Manifest
@@ -0,0 +1,4 @@
+DIST Path-IsDev-1.001003.tar.gz 188687 SHA256 37d66bfe205d7916824a46ad6290b8fb170fc602c16f8dc8169576f2ad682949 SHA512 fd4e355d0e67ec210eba443d5867dce181664da6ae300d81b98e77fd78a25d5a4f95e0b901f0a6c7596f28a3e2e37264f31226c410f5e6fb6a565d2ef0618d59 WHIRLPOOL 68e254bd060f399341ec2827495911b7b026332106da6dd7709c8656f64f436ec4494883cec772ba60196422f715b7ec7ec643d24d7a45e79ea2b9ad7cfc3913
+EBUILD Path-IsDev-1.1.3.ebuild 859 SHA256 cc3ff6cb117da4961442f6c37728ce3e6a961046039b0769ea3a8cbf1861c008 SHA512 3ab7881c60bcf8d169ee3ba94f1a874cb6ad360238a03bf77a8f9f476adf5ef17195573e7dc06ba99410e2af2167b3e0402e52ef441ca2b96c70d4dd90c31108 WHIRLPOOL bf42ea3e8ad557d34ae8a83db57db9f4eaf598604ada73d7588d6f880fac1a8396f2bd751755d9e0a62a1c7019073673b19cca5231d14a41456102740a27b4cf
+MISC ChangeLog 525 SHA256 9458a07396907053290f7fccbbded9e3867246a15ac02f2fd7617b6650be7db5 SHA512 e1dc8d35279d9a5292c9244c513c217ad662f2be123dc73dfeeba2489bcb6c54c45d7edd0b1f70cbdf310653f3152a86299c42b22deb328af5dd571218b796c8 WHIRLPOOL 7008d051e56c4b0169befb7ee09f5aaec087d1917d8a1c395a135bf73fdd7a568272405d796f845b4ed49ad8f66585ade0fffe82b717737a32d0d797d909c34a
+MISC metadata.xml 2593 SHA256 ce581448e6055fc8ae610d2d922911e011db9f9bf0a8782209edf8130ea6814e SHA512 230f2273845df5314d8ad3e2174ee8c7eadb3655fde12ce1cba533bb53b410425eae8d038a0926e8a114c99fa5f8ef85e372d8c39178bac2546b7b35bf84e661 WHIRLPOOL ac4f2dc19b3719492593b9c52e0bd04ab50504f14a9c0c52b896fe2ecec14d6d3de1985e30a9702cc839fb79927a84592f1ab0ddeb83606e93754a134aac3bb9
diff --git a/dev-perl/Path-IsDev/Path-IsDev-1.1.3.ebuild b/dev-perl/Path-IsDev/Path-IsDev-1.1.3.ebuild
new file mode 100644
index 000000000000..160e9c561bc9
--- /dev/null
+++ b/dev-perl/Path-IsDev/Path-IsDev-1.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KENTNL
+DIST_VERSION=1.001003
+inherit perl-module
+
+DESCRIPTION="Determine if a given Path resembles a development source tree"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Class-Tiny-0.10.0
+ dev-perl/File-HomeDir
+ dev-perl/Module-Runtime
+ >=dev-perl/Path-Tiny-0.4.0
+ dev-perl/Role-Tiny
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Sub-Exporter
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ !minimal? ( >=virtual/perl-ExtUtils-MakeMaker-7.0.0 )
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=virtual/perl-Test-Simple-0.990.0
+ )
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Path-IsDev/metadata.xml b/dev-perl/Path-IsDev/metadata.xml
new file mode 100644
index 000000000000..f11ae9c5955b
--- /dev/null
+++ b/dev-perl/Path-IsDev/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Path-IsDev</remote-id>
+ <remote-id type="cpan-module">Path::IsDev</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::Changelog</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::DevDirMarker</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::META</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::MYMETA</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::Makefile</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::TestDir</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::Tool::Dzil</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::Tool::MakeMaker</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::Tool::ModuleBuild</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::VCS::Git</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::HeuristicSet::Basic</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::NegativeHeuristic::HomeDir</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::NegativeHeuristic::IsDev::IgnoreFile</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::NegativeHeuristic::PerlINC</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Object</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Result</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Heuristic</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::HeuristicSet</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::HeuristicSet::Simple</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::Child::BaseName::MatchRegexp</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::Child::BaseName::MatchRegexp::File</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::Child::Exists::Any</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::Child::Exists::Any::Dir</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::Child::Exists::Any::File</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::FullPath::Is::Any</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::NegativeHeuristic</remote-id>
+ </upstream>
+</pkgmetadata>