summaryrefslogtreecommitdiff
path: root/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
commitc85a90f90521c7e11d618b527d6630cc64cecbd4 (patch)
tree27c1f04d8eab0e0140fb62887a6a5d4d87c32ad9 /dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild
parent2f51c9978dda4c6e8debca43e4235ecc86914032 (diff)
gentoo resync : 26.12.2017
Diffstat (limited to 'dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild')
-rw-r--r--dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild
new file mode 100644
index 000000000000..2917e8496957
--- /dev/null
+++ b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=YANICK
+DIST_VERSION=0.20
+inherit perl-module
+
+DESCRIPTION="Utility methods and base class for manipulating Perl via PPI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Class-XSAccessor-1.20.0
+ virtual/perl-File-Spec
+ >=dev-perl/PPI-1.215.0
+ dev-perl/Try-Tiny
+"
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ ${RDEPEND}
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ >=dev-perl/Test-Differences-0.480.100
+ dev-perl/Test-Exception
+ dev-perl/Test-Most
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=("${FILESDIR}/${PN}-0.20-fix-pseudo-deps.patch")