summaryrefslogtreecommitdiff
path: root/dev-perl/PPI/PPI-1.224.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/PPI/PPI-1.224.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/PPI/PPI-1.224.0.ebuild')
-rw-r--r--dev-perl/PPI/PPI-1.224.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/PPI/PPI-1.224.0.ebuild b/dev-perl/PPI/PPI-1.224.0.ebuild
new file mode 100644
index 000000000000..47a8d217ec81
--- /dev/null
+++ b/dev-perl/PPI/PPI-1.224.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MITHALDU
+DIST_VERSION=1.224
+inherit perl-module
+
+DESCRIPTION="Parse, Analyze and Manipulate Perl (without perl)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Clone-0.300.0
+ >=virtual/perl-Digest-MD5-2.350.0
+ >=virtual/perl-File-Spec-3.270.100
+ >=dev-perl/IO-String-1.70.0
+ >=dev-perl/List-MoreUtils-0.160.0
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ >=dev-perl/Params-Util-1.000.0
+ >=virtual/perl-Storable-2.170.0
+ dev-perl/Task-Weaken
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? (
+ >=dev-perl/Class-Inspector-1.220.0
+ >=dev-perl/File-Remove-1.420.0
+ dev-perl/Test-Deep
+ >=virtual/perl-Test-Simple-0.860.0
+ >=dev-perl/Test-Object-0.70.0
+ >=dev-perl/Test-SubCalls-1.70.0
+ >=dev-perl/Test-Warn-0.300.0
+ )
+"
+PATCHES=("${FILESDIR}/${P}-t-marpa-dot-inc.patch")