summaryrefslogtreecommitdiff
path: root/dev-perl/PDL/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/PDL/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/PDL/files')
-rw-r--r--dev-perl/PDL/files/PDL-2.17.0-dot-in-inc.patch142
-rw-r--r--dev-perl/PDL/files/PDL-2.17.0-fortran.patch22
-rw-r--r--dev-perl/PDL/files/PDL-2.17.0-makemakerfix.patch20
-rw-r--r--dev-perl/PDL/files/PDL-2.17.0-shared-hdf.patch44
-rw-r--r--dev-perl/PDL/files/perldl.conf110
5 files changed, 338 insertions, 0 deletions
diff --git a/dev-perl/PDL/files/PDL-2.17.0-dot-in-inc.patch b/dev-perl/PDL/files/PDL-2.17.0-dot-in-inc.patch
new file mode 100644
index 000000000000..0007f47b91d5
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.17.0-dot-in-inc.patch
@@ -0,0 +1,142 @@
+From 717a19da57ec9f8fc80d4824cad47a04200fc515 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sat, 24 Jun 2017 17:27:27 +1200
+Subject: [PATCH] Backport fix for "." in @INC from 2.018
+
+2.018 has far too many changes to safely review in such a short amount
+of time. Fixing this trivial build issue gets us what is necessary
+for Perl 5.26 roll-out without lots of additional verification
+---
+ Basic/Core/Core.xs | 2 +-
+ Basic/Core/pdl.h.PL | 2 +-
+ Basic/Core/pdlconv.c.PL | 4 ++--
+ Basic/Core/pdlcore.c.PL | 4 ++--
+ Basic/Core/pdlcore.h.PL | 4 ++--
+ Basic/Core/pdlsimple.h.PL | 2 +-
+ Makefile.PL | 4 ++--
+ 7 files changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/Basic/Core/Core.xs b/Basic/Core/Core.xs
+index 5e95356..b38f14c 100644
+--- a/Basic/Core/Core.xs
++++ b/Basic/Core/Core.xs
+@@ -336,7 +336,7 @@ iscontig(x)
+
+ # using "perl" not $^X because that doesn't work on "perl in space"
+ # TODO: switching back to $^X since using "perl" is not a viable fix
+-INCLUDE_COMMAND: $^X -e "require q{Dev.pm}; PDL::Core::Dev::generate_core_flags()"
++INCLUDE_COMMAND: $^X -e "require q{./Dev.pm}; PDL::Core::Dev::generate_core_flags()"
+
+ #if 0
+ =begin windows_mmap
+diff --git a/Basic/Core/pdl.h.PL b/Basic/Core/pdl.h.PL
+index d2e9758..6e01445 100644
+--- a/Basic/Core/pdl.h.PL
++++ b/Basic/Core/pdl.h.PL
+@@ -6,7 +6,7 @@ use Config;
+ use File::Basename qw(&basename &dirname);
+
+ # how many variable types (ie PDL_Byte, ...) are there?
+-require 'Types.pm';
++require './Types.pm';
+ my $ntypes = $#PDL::Types::names;
+ my $PDL_DATATYPES = PDL::Types::datatypes_header();
+
+diff --git a/Basic/Core/pdlconv.c.PL b/Basic/Core/pdlconv.c.PL
+index 160e29b..62a57b0 100644
+--- a/Basic/Core/pdlconv.c.PL
++++ b/Basic/Core/pdlconv.c.PL
+@@ -7,9 +7,9 @@ use strict;
+ use Config;
+ use File::Basename qw(&basename &dirname);
+
+-require 'Dev.pm'; PDL::Core::Dev->import;
++require './Dev.pm'; PDL::Core::Dev->import;
+ use vars qw( %PDL_DATATYPES );
+-require 'Types.pm'; #for typesrtkeys
++require './Types.pm'; #for typesrtkeys
+
+ # This forces PL files to create target in same directory as PL file.
+ # This is so that make depend always knows where to find PL derivatives.
+diff --git a/Basic/Core/pdlcore.c.PL b/Basic/Core/pdlcore.c.PL
+index a602b6e..445cfb8 100644
+--- a/Basic/Core/pdlcore.c.PL
++++ b/Basic/Core/pdlcore.c.PL
+@@ -6,7 +6,7 @@ use strict;
+ use Config;
+ use File::Basename qw(&basename &dirname);
+
+-require 'Dev.pm'; PDL::Core::Dev->import;
++require './Dev.pm'; PDL::Core::Dev->import;
+ use vars qw( %PDL_DATATYPES );
+
+ # check for bad value support
+@@ -14,7 +14,7 @@ require './Config.pm'; # to load the PDL not the Perl one
+ die "No PDL::Config found" unless %PDL::Config;
+ my $bvalflag = $PDL::Config{WITH_BADVAL};
+ my $usenan = $PDL::Config{BADVAL_USENAN};
+-require 'Types.pm';
++require './Types.pm';
+ PDL::Types->import(':All');
+
+
+diff --git a/Basic/Core/pdlcore.h.PL b/Basic/Core/pdlcore.h.PL
+index 90469f0..760e6a1 100644
+--- a/Basic/Core/pdlcore.h.PL
++++ b/Basic/Core/pdlcore.h.PL
+@@ -11,7 +11,7 @@ use strict;
+ use Config;
+ use File::Basename qw(&basename &dirname);
+
+-require 'Dev.pm'; PDL::Core::Dev->import;
++require './Dev.pm'; PDL::Core::Dev->import;
+ use vars qw( %PDL_DATATYPES );
+
+ # version 2 is for versions after PDL 2.1.1
+@@ -349,7 +349,7 @@ double NaN_double;
+
+ # fortunately it looks like Types.pm.PL is processed before this
+ # file
+- require "Types.pm"; # ie PDL::Types
++ require "./Types.pm"; # ie PDL::Types
+
+ for (PDL::Types::typesrtkeys()) {
+ my $ctype = $PDL::Types::typehash{$_}{ctype};
+diff --git a/Basic/Core/pdlsimple.h.PL b/Basic/Core/pdlsimple.h.PL
+index e511913..43eb557 100644
+--- a/Basic/Core/pdlsimple.h.PL
++++ b/Basic/Core/pdlsimple.h.PL
+@@ -3,7 +3,7 @@
+ use Config;
+ use File::Basename qw(&basename &dirname);
+
+-require 'Types.pm';
++require './Types.pm';
+ my $PDL_DATATYPES = PDL::Types::datatypes_header();
+
+ # List explicitly here the variables you want Configure to
+diff --git a/Makefile.PL b/Makefile.PL
+index fc8d590..a94d895 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -226,7 +226,7 @@ sub check_f77conf {
+
+ sub make_Version_pm {
+ # Get Version from Basic/PDL.pm and generated Basic/Core/Version.pm from it
+- require 'Basic/PDL.pm';
++ require './Basic/PDL.pm';
+ # keep version info in $PDL::Config
+ $PDL::Config{PDL_BUILD_VERSION} = "$PDL::VERSION";
+
+@@ -376,7 +376,7 @@ make_Types_pm();
+ # this will make PDL::Core::Dev's functions available
+ # in Makefile.PL files in all subdirectories
+ # IMPORTANT: it has to be after make_Types_pm()
+-require "Basic/Core/Dev.pm"; PDL::Core::Dev->import();
++require "./Basic/Core/Dev.pm"; PDL::Core::Dev->import();
+
+ # only perform one test if required modules are missing
+ # the test will print an informational message and fail
+--
+2.13.1
+
diff --git a/dev-perl/PDL/files/PDL-2.17.0-fortran.patch b/dev-perl/PDL/files/PDL-2.17.0-fortran.patch
new file mode 100644
index 000000000000..8d02a2685cfa
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.17.0-fortran.patch
@@ -0,0 +1,22 @@
+--- a/Lib/Minuit/Makefile.PL
++++ b/Lib/Minuit/Makefile.PL
+@@ -149,7 +149,7 @@
+ ("
+
+ minuitlib/$_\$(OBJ_EXT): minuitlib/$_.f
+- $mycompiler -c $hack_64bit -o minuitlib/$_\$(OBJ_EXT) $mycflags minuitlib/$_.f
++ \$(FC) \$(FFLAGS) -fPIC -c -o minuitlib/$_\$(OBJ_EXT) $mycflags minuitlib/$_.f
+ " )} @minuitfiles;
+
+ if (!defined($PDL::Config{MINUIT_LIB})){
+--- a/Lib/Slatec/Makefile.PL
++++ b/Lib/Slatec/Makefile.PL
+@@ -136,7 +136,7 @@
+ ("
+
+ slatec/$_\$(OBJ_EXT): slatec/$_.f
+- $mycompiler -c $hack_64bit -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
++ \$(FC) \$(FFLAGS) -c -fPIC -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
+ " )} @slatecfiles;
+
+ }
diff --git a/dev-perl/PDL/files/PDL-2.17.0-makemakerfix.patch b/dev-perl/PDL/files/PDL-2.17.0-makemakerfix.patch
new file mode 100644
index 000000000000..b564a95db3cd
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.17.0-makemakerfix.patch
@@ -0,0 +1,20 @@
+--- a/Demos/BAD2_demo.pm.PL 2006/04/20 07:42:24 1.1
++++ b/Demos/BAD2_demo.pm.PL 2006/04/20 07:42:32
+@@ -3,6 +3,7 @@
+ # - requires both bad-value support and PGPLOT
+ #
+
++use blib;
+ use strict;
+
+ use Config;
+--- a/Demos/BAD_demo.pm.PL 2006/04/20 07:42:17 1.1
++++ b/Demos/BAD_demo.pm.PL 2006/04/20 07:42:38
+@@ -3,6 +3,7 @@
+ # - needed since we allow bad pixel handling to be switched off
+ #
+
++use blib;
+ use strict;
+
+ use Config;
diff --git a/dev-perl/PDL/files/PDL-2.17.0-shared-hdf.patch b/dev-perl/PDL/files/PDL-2.17.0-shared-hdf.patch
new file mode 100644
index 000000000000..0937b98864a4
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.17.0-shared-hdf.patch
@@ -0,0 +1,44 @@
+diff -ruN PDL-2.017.orig/IO/HDF/Makefile.PL PDL-2.017/IO/HDF/Makefile.PL
+--- PDL-2.017.orig/IO/HDF/Makefile.PL 2016-09-23 12:43:47.000000000 +0200
++++ PDL-2.017/IO/HDF/Makefile.PL 2016-10-27 22:09:04.048315756 +0200
+@@ -56,25 +56,25 @@
+
+ # Look for the libs:
+ foreach my $libdir ( @HDF_lib_locations ) {
+- if (-e "$libdir/libdfalt.a" && !$found_df) {
++ if (-e "$libdir/libdfalt.$Config{so}" && !$found_df) {
+ $found_df = 1;
+ $hdf_lib_path = $libdir;
+ $hdf_libs = '-lmfhdfalt -ldfalt';
+- print "Found libdfalt.a at $libdir/libdfalt.a\n";
++ print "Found libdfalt.$Config{so} at $libdir/libdfalt.$Config{so}\n";
+ }
+
+- if (-e "$libdir/libdf.a" && !$found_df) {
++ if (-e "$libdir/libdf.$Config{so}" && !$found_df) {
+ $found_df = 1;
+ $hdf_lib_path = $libdir;
+ $hdf_libs = '-lmfhdf -ldf';
+- print "Found libdf.a at $libdir/libdf.a\n";
++ print "Found libdf.$Config{so} at $libdir/libdf.$Config{so}\n";
+ }
+
+- if (-e "$libdir/libhdf.a" && !$found_df) {
++ if (-e "$libdir/libhdf.$Config{so}" && !$found_df) {
+ $found_df = 1;
+ $hdf_lib_path = $libdir;
+ $hdf_libs = '-lmfhdf -lhdf -lxdr';
+- print "Found libhdf.a at $libdir/libhdf.a\n";
++ print "Found libhdf.$Config{so} at $libdir/libhdf.$Config{so}\n";
+ }
+
+ # Look for the szip library, which HDF >= 4.2r0 needs, but older versions don't!
+@@ -91,7 +91,7 @@
+ } # foreach $libdir...
+
+ unless( defined( $hdf_lib_path ) ) {
+- $msg .= "Cannot find hdf library, libdf.a.\n"
++ $msg .= "Cannot find hdf library, libdf.$Config{so}.\n"
+ . "Please add the correct library path to Makefile.PL or install HDF\n";
+ }
+
diff --git a/dev-perl/PDL/files/perldl.conf b/dev-perl/PDL/files/perldl.conf
new file mode 100644
index 000000000000..1fe24f3db6b0
--- /dev/null
+++ b/dev-perl/PDL/files/perldl.conf
@@ -0,0 +1,110 @@
+# -*-perl-*-
+
+# PDL Configuration options
+
+# You can edit this here or say 'perl Makefile.PL PDLCONF=file'
+# or use ~/.perldl.conf
+
+# Note in general "0" means False, "1" means "True" and "undef"
+# means "Try if possible (e.g. because the library is found)"
+
+%PDL_CONFIG = (
+
+# Use posix threading to make use of multiprocessor machines
+# undef -> try if possible
+# 0 -> don't use
+# true -> force use
+
+ WITH_POSIX_THREADS => undef,
+
+ MALLOCDBG => undef,
+# {
+# include => '-I/home/csoelle/tmp',
+# libs => '-L/home/csoelle/tmp -lmymalloc',
+# define => << 'EOD',
+##define malloc(n) dbgmalloc(n,__FILE__,__LINE__)
+##define free(p) dbgfree(p)
+#EOD
+# include => '',
+# libs => '-lefence',
+# define => '',
+# },
+
+# Do we want routines to handle bad values?
+# saying no will make PDL a bit faster
+# true -> yes
+# false -> no, undef -> no
+#
+ WITH_BADVAL => 0,
+# WITH_BADVAL => 1,
+
+# if WITH_BADVAL == 1, do we use NaN/Inf to represent badvalues
+# (not convinced setting this results in faster code)
+#
+ BADVAL_USENAN => 0,
+# BADVAL_USENAN => 1,
+
+# Try to build Graphics/TriD
+ WITH_3D => undef,
+#
+# For Mesa 3.2
+#
+ OPENGL_LIBS => '-L/usr/lib -lGL -lGLU -L/usr/X11R6/lib -lXext -lX11',
+#
+# Mesa need -DGL_GLEXT_LEGACY for glPolygonOffsetEXT amoung others
+#
+ OPENGL_DEFINE => '-DGL_GLEXT_LEGACY',
+ OPENGL_INC => '-I/usr/include',
+#
+#
+# For SGI GL
+#
+# OPENGL_LIBS => '-lGL -lGLU -lXext -lX11',
+# OPENGL_INC => '',
+# OPENGL_DEFINE => '',
+#
+# Let perl try to figure it out
+# OPENGL_LIBS => undef,
+# OPENGL_INC => undef,
+# OPENGL_DEFINE => undef,
+# Whether or not to build the Karma interface module
+
+ WITH_KARMA => undef, # Leave it up to PDL to decide
+ WHERE_KARMA => undef, # you may explicitly specify directory location
+
+# Whether or not to build the PDL::Slatec module
+# 0 -> don't use
+# true -> force use
+
+ WITH_SLATEC => undef, # Leave it up to PDL to decide
+
+# Whether or not to build the PDL::GSL module
+# 0 -> don't use
+# true -> force use
+
+ WITH_GSL => undef, # Leave it up to PDL to decide
+
+# Location to search for the GSL libs
+ GSL_LIBS => [ '/lib','/usr/lib','/usr/local/lib'],
+# Location to find GSL includes:
+ GSL_INC => '-I/usr/include/gsl -I/usr/local/include',
+
+# Whether or not to build the PDL::FFTW module
+# 0 -> don't use
+# true -> force use
+
+ WITH_FFTW => undef, # Leave it up to PDL to decide
+
+# Location to search for the FFTW libs
+ FFTW_LIBS => [ '/lib','/usr/lib','/usr/local/lib'],
+# Location to find FFTW includes:
+ FFTW_INC => ['/usr/include/','/usr/local/include'],
+
+# FFTW Numeric Precision Type to link in: (double or single precision)
+ FFTW_TYPE => 'double',
+
+);
+
+1; # Return OK status on 'require'
+
+