summaryrefslogtreecommitdiff
path: root/dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-18 15:11:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-18 15:11:02 +0000
commit0fb71e0215ed52863e462cccef73c01aff44d43d (patch)
tree428fc3fa92f9c69ed02878e9b6151a9fb810e651 /dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild
parent9bd54251864651f49e673a08aec9ef79cfe08f04 (diff)
gentoo resync : 18.12.2017
Diffstat (limited to 'dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild')
-rw-r--r--dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild b/dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild
new file mode 100644
index 000000000000..32f794ca21f1
--- /dev/null
+++ b/dev-perl/Net-Whois-IP/Net-Whois-IP-1.190.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_VERSION=${PV%0.0}
+DIST_AUTHOR=BSCHMITZ
+inherit perl-module
+
+DESCRIPTION="Perl extension for looking up the whois information for ip addresses"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+PERL_RM_FILES=(
+ "test.pl" # gets installed otherwise :(
+)
+RDEPEND="
+ dev-perl/Regexp-IPv6
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_test() {
+ local MODULES=(
+ "Net::Whois::IP ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ # # All tests defined require networking
+ # and all fail.
+ # https://rt.cpan.org/Public/Bug/Display.html?id=110961
+ # local my_test_control
+ # my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
+ # if ! has network ${my_test_control} ; then
+ # perl_rm_files "t/test1.t" "t/testx.t"
+ # fi
+ # perl-module_src_test
+}