summaryrefslogtreecommitdiff
path: root/dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild
deleted file mode 100644
index fef8456706e8..000000000000
--- a/dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=CHRISN
-DIST_VERSION=1.88
-DIST_EXAMPLES=("examples/*")
-inherit multilib perl-module
-
-DESCRIPTION="Perl extension for using OpenSSL"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="libressl test minimal examples"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- virtual/perl-MIME-Base64
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- test? (
- !minimal? (
- dev-perl/Test-Exception
- dev-perl/Test-Warn
- dev-perl/Test-NoWarnings
- )
- virtual/perl-Test-Simple
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.88-fix-network-tests.patch"
- "${FILESDIR}/${PN}-1.88-fix-libdir.patch"
-)
-PERL_RM_FILES=(
- # Hateful author tests
- 't/local/01_pod.t'
- 't/local/02_pod_coverage.t'
- 't/local/kwalitee.t'
-)
-
-src_configure() {
- if use test && has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
- export NETWORK_TESTS=yes
- else
- use test && einfo "Network tests will be skipped without DIST_TEST_OVERRIDE=~network"
- export NETWORK_TESTS=no
- fi
- export LIBDIR=$(get_libdir)
- perl-module_src_configure
-}
-
-src_compile() {
- mymake=(
- OPTIMIZE="${CFLAGS}"
- OPENSSL_PREFIX="${EPREFIX}"/usr
- )
- perl-module_src_compile
-}