summaryrefslogtreecommitdiff
path: root/dev-perl/Net-SNMP/Net-SNMP-6.0.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-perl/Net-SNMP/Net-SNMP-6.0.1-r3.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-perl/Net-SNMP/Net-SNMP-6.0.1-r3.ebuild')
-rw-r--r--dev-perl/Net-SNMP/Net-SNMP-6.0.1-r3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Net-SNMP/Net-SNMP-6.0.1-r3.ebuild b/dev-perl/Net-SNMP/Net-SNMP-6.0.1-r3.ebuild
new file mode 100644
index 000000000000..ac07cf24a685
--- /dev/null
+++ b/dev-perl/Net-SNMP/Net-SNMP-6.0.1-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_VERSION=v${PV}
+DIST_AUTHOR=DTOWN
+inherit perl-module
+
+DESCRIPTION="A SNMP Perl Module"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~sparc-solaris ~x86-solaris"
+IUSE="examples minimal"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/Crypt-DES-2.30.0
+ >=dev-perl/Crypt-Rijndael-1.20.0
+ >=dev-perl/Digest-HMAC-1.0
+ >=virtual/perl-Digest-MD5-2.110.0
+ >=dev-perl/Digest-SHA1-1.20.0
+ >=dev-perl/Socket6-0.230.0
+ )
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-IO
+ virtual/perl-Math-BigInt
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.0
+ test? ( virtual/perl-Test )
+"
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+ fi
+}