summaryrefslogtreecommitdiff
path: root/dev-perl/Net-Pcap/Net-Pcap-0.180.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-perl/Net-Pcap/Net-Pcap-0.180.0-r1.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-perl/Net-Pcap/Net-Pcap-0.180.0-r1.ebuild')
-rw-r--r--dev-perl/Net-Pcap/Net-Pcap-0.180.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Net-Pcap/Net-Pcap-0.180.0-r1.ebuild b/dev-perl/Net-Pcap/Net-Pcap-0.180.0-r1.ebuild
new file mode 100644
index 000000000000..e3b237b2e2b4
--- /dev/null
+++ b/dev-perl/Net-Pcap/Net-Pcap-0.180.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SAPER
+DIST_VERSION=0.18
+DIST_EXAMPLES=( "eg/*" )
+inherit perl-module
+
+DESCRIPTION="Interface to the pcap(3) LBL packet capture library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="net-libs/libpcap
+ dev-perl/IO-Interface"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-libpcap-1.9.0.patch"
+ "${FILESDIR}/${PN}-${DIST_VERSION}-test-error.patch"
+)
+
+src_test() {
+ if [[ $EUID != 0 ]]; then
+ elog "Comprehensive testing of this module requires root permissions."
+ elog "For details, see:"
+ elog "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+ fi
+ perl_rm_files t/pod{,cover,spell}.t t/distchk.t t/portfs.t
+ perl-module_src_test
+}