summaryrefslogtreecommitdiff
path: root/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild')
-rw-r--r--dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild b/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild
new file mode 100644
index 000000000000..e263517f0078
--- /dev/null
+++ b/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=GRUBER
+MODULE_VERSION=1.22
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Patricia Trie perl module for fast IP address lookups"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="dev-perl/Net-CIDR-Lite
+ ipv6? (
+ dev-perl/Socket6
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
+
+#SRC_TEST="do"