summaryrefslogtreecommitdiff
path: root/dev-perl/Monitoring-Plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Monitoring-Plugin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Monitoring-Plugin')
-rw-r--r--dev-perl/Monitoring-Plugin/Manifest3
-rw-r--r--dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild33
-rw-r--r--dev-perl/Monitoring-Plugin/metadata.xml23
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-perl/Monitoring-Plugin/Manifest b/dev-perl/Monitoring-Plugin/Manifest
new file mode 100644
index 000000000000..cd332e37dbee
--- /dev/null
+++ b/dev-perl/Monitoring-Plugin/Manifest
@@ -0,0 +1,3 @@
+DIST Monitoring-Plugin-0.39.tar.gz 62733 BLAKE2B eaf623b0bb84f1127f23637ba1a46a1de4b1732b7e55feaac4dd8eb22ccdd13ae097fa79054df43e300f78e924423c092cade99c9c9210289f7d22cba5f8b959 SHA512 7bdba894cffc0839586e52f3667157cf578e94734ddc0ccd05899f631271e5b69e9cbfe4b2fb59f68b45e1d13afc82b095b65e249527f2c448a38b93e510a05c
+EBUILD Monitoring-Plugin-0.390.0.ebuild 762 BLAKE2B de529f018369d06bc60cdc0188be0cdbff4fe5e2bce7c1be6d8b0d12e142586822ece170793320922bc25cea83995bedd6281f32be25252045a524129cea1cf9 SHA512 6283d7081e52c935c0273353de25701d9beeab958e387a85edee3742aec70d50c67458f6dac129a03b4e00732f93c153ac7cec83d992055634df7700a79f3ce5
+MISC metadata.xml 1044 BLAKE2B 9968044476f7e864d419844f82d787d28f29583d2357473eba06746c98aa778f98f1103c91489681967b82b27baf02771c9bc9d068620f719b83f3c8e345218f SHA512 1a366c66b7e20a0cffa2059e2987f1837c6e04b5003d2b3f80a7e0f786c1c8cbb80c8d3adda6239b119b23bde04acaf282faec17514094058aebac877fe3218a
diff --git a/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild b/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild
new file mode 100644
index 000000000000..6f5e1125aa8a
--- /dev/null
+++ b/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NIERLEIN
+DIST_VERSION=0.39
+inherit perl-module
+
+DESCRIPTION="Modules to streamline Nagios, Icinga, Shinken, etc. plugins"
+
+SLOT="0"
+KEYWORDS="amd64 hppa sparc x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Class-Accessor
+ dev-perl/Config-Tiny
+ virtual/perl-File-Spec
+ dev-perl/Math-Calc-Units
+ dev-perl/Params-Validate
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? ( >=virtual/perl-Test-Simple-0.620.0 )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/Monitoring-Plugin/metadata.xml b/dev-perl/Monitoring-Plugin/metadata.xml
new file mode 100644
index 000000000000..d592578c778f
--- /dev/null
+++ b/dev-perl/Monitoring-Plugin/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Monitoring-Plugin</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Config</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::ExitResult</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Functions</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Getopt</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Performance</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Range</remote-id>
+ <remote-id type="cpan-module">Monitoring::Plugin::Threshold</remote-id>
+ </upstream>
+</pkgmetadata>