summaryrefslogtreecommitdiff
path: root/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild')
-rw-r--r--dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild b/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild
new file mode 100644
index 000000000000..47d6e47d6dee
--- /dev/null
+++ b/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DLAMBLEY
+DIST_VERSION=${PV%.0}
+inherit perl-module
+
+DESCRIPTION="MogileFS Client using AnyEvent non-blocking IO"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/IO-AIO
+ dev-perl/AnyEvent
+ dev-perl/AnyEvent-HTTP
+ dev-perl/File-Slurp
+ >=dev-perl/MogileFS-Client-1.16
+ dev-perl/Try-Tiny
+ dev-perl/namespace-clean
+"
+DEPEND="${RDEPEND}"
+
+# Tests only available if you have a local mogilefsd on 127.0.0.1:7001
+DIST_TEST=skip
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}