summaryrefslogtreecommitdiff
path: root/dev-perl/MaxMind-DB-Common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-perl/MaxMind-DB-Common
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-perl/MaxMind-DB-Common')
-rw-r--r--dev-perl/MaxMind-DB-Common/Manifest3
-rw-r--r--dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild49
-rw-r--r--dev-perl/MaxMind-DB-Common/metadata.xml21
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-perl/MaxMind-DB-Common/Manifest b/dev-perl/MaxMind-DB-Common/Manifest
new file mode 100644
index 000000000000..a4b37ba45199
--- /dev/null
+++ b/dev-perl/MaxMind-DB-Common/Manifest
@@ -0,0 +1,3 @@
+DIST MaxMind-DB-Common-0.040001.tar.gz 22195 BLAKE2B c242abe2786bebb4f045d8e454e5044fa7c53db77b589e2d49f37d21f59d221e5ed543aa15c906cf8259b15b217b1bb103f5034c1ffdb10b6c2d89e2b5e97183 SHA512 4748ac66e09ec3c8017b7365562b8273399c85f359c35b22868e1b86e80e8a59a3a3fbfd851becf0ac997657b4e8288057204a2e14bb699815676f3214f6345c
+EBUILD MaxMind-DB-Common-0.40.1.ebuild 1028 BLAKE2B a42db06d50bfe8fe868dd23a192627566e8ed9de83f07d37f886a1a13d978da8ea63427ac22d30337e3ed5aba9452f649d586ea5c17f10ca618ed4ecf6f4acc9 SHA512 9bc55b766cb2074118b38bde53aca23d873d72ace8939931c94875380ebd65115f396a8158ad360aa9b94c9d3cd725ca5b6672d3b53e7d065f0bc8b12c16a9b6
+MISC metadata.xml 885 BLAKE2B 62c498c09416853821cc2896188df2a689042b89ad5aeacb48d5e7ae52acdf1a861ffe1a38045f31a22a719241ea41db22afd3cd69284e2b53ddc13b50e2ac95 SHA512 7528fd249e3466e097880e507a45698c43de182c9fe128fe562aee15ec07c0f6a8908d735c95c9e18a1fa24e0cbb639fcbcfca24e111f29a4cf49407d9f05763
diff --git a/dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild b/dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild
new file mode 100644
index 000000000000..1ae432918d16
--- /dev/null
+++ b/dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MAXMIND
+DIST_VERSION=0.040001
+inherit perl-module
+
+DESCRIPTION="Code shared by the MaxMind DB reader and writer modules"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Data-Dumper-Concise
+ dev-perl/DateTime
+ virtual/perl-Exporter
+ dev-perl/List-AllUtils
+ virtual/perl-Math-BigInt
+ dev-perl/Moo
+ dev-perl/MooX-StrictConstructor
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Sub-Quote
+ virtual/perl-autodie
+ dev-perl/namespace-autoclean
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-00-compile.t"
+ "t/author-eol.t"
+ "t/author-no-tabs.t"
+ "t/author-pod-spell.t"
+ "t/author-pod-syntax.t"
+ "t/author-test-version.t"
+ "t/release-cpan-changes.t"
+ "t/release-portability.t"
+ "t/release-synopsis.t"
+ "t/release-tidyall.t"
+)
diff --git a/dev-perl/MaxMind-DB-Common/metadata.xml b/dev-perl/MaxMind-DB-Common/metadata.xml
new file mode 100644
index 000000000000..dec1ce3b6fa0
--- /dev/null
+++ b/dev-perl/MaxMind-DB-Common/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">MaxMind-DB-Common</remote-id>
+ <remote-id type="cpan-module">MaxMind::DB::Common</remote-id>
+ <remote-id type="cpan-module">MaxMind::DB::Metadata</remote-id>
+ <remote-id type="cpan-module">MaxMind::DB::Role::Debugs</remote-id>
+ <remote-id type="cpan-module">MaxMind::DB::Types</remote-id>
+ <remote-id type="cpan-module">Test::MaxMind::DB::Common::Data</remote-id>
+ <remote-id type="cpan-module">Test::MaxMind::DB::Common::Util</remote-id>
+ </upstream>
+</pkgmetadata>