summaryrefslogtreecommitdiff
path: root/dev-perl/Math-Int64
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-perl/Math-Int64
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-perl/Math-Int64')
-rw-r--r--dev-perl/Math-Int64/Manifest3
-rw-r--r--dev-perl/Math-Int64/Math-Int64-0.540.0.ebuild34
-rw-r--r--dev-perl/Math-Int64/metadata.xml19
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-perl/Math-Int64/Manifest b/dev-perl/Math-Int64/Manifest
new file mode 100644
index 000000000000..7fa4ceb39307
--- /dev/null
+++ b/dev-perl/Math-Int64/Manifest
@@ -0,0 +1,3 @@
+DIST Math-Int64-0.54.tar.gz 119664 BLAKE2B cf12dd1f156c92cbbd2f87913737cd1a4b48ef3d879e340506241bea6debcdc2313f8c1503597f54a0d80e6e50f16cbdba5be112e4e6df71e1f2c38575c423c3 SHA512 03677df499ebc3924fabefbc6fb863adc2f765341a9697305b03bb24477b391029e65cc492c831a24e282e26e850082abbd0e52dda198aa041f3f4f41cc4f995
+EBUILD Math-Int64-0.540.0.ebuild 756 BLAKE2B 28f4013172edf3cb41191e8a9f6fb48cfd0cea959aa50517d7cdddb1243009a22f4e53a7cd8a4c5943039fa35663d15b1f17da9c30cc5e797b867ec6dc899b77 SHA512 117b2ae5859659f1e0635667055ae46c7d83220d5575423864d4db266739aea9f7ff681fbc73e35f102648293dd506306234156a9fdf63f4349274f546f60d9d
+MISC metadata.xml 722 BLAKE2B 18e431fced9526df6ee2595919b3effbbac89a1b20051ce694007b1398a3e3698664ad5df5eedad9a19fccc8b6d21c0fe8f6286bab5dc5531cbbf79c8a99dc62 SHA512 9f536545a2c8a8bf4e9e5fa04684ff58f414f0fdcf8be5421785b0a3a04978bee8abe86ff79ef9fa1db02b48a0a832ed73e349143eff594a82b646ce40dbdd4b
diff --git a/dev-perl/Math-Int64/Math-Int64-0.540.0.ebuild b/dev-perl/Math-Int64/Math-Int64-0.540.0.ebuild
new file mode 100644
index 000000000000..f823edafd09e
--- /dev/null
+++ b/dev-perl/Math-Int64/Math-Int64-0.540.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.54
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Manipulate 64 bits integers in Perl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Storable
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-eol.t" "t/author-no-tabs.t" "t/author-pod-spell.t"
+ "t/author-pod-syntax.t" "t/release-cpan-changes.t" "t/release-pod-coverage.t"
+ "t/release-portability.t" "t/release-synopsis.t"
+)
diff --git a/dev-perl/Math-Int64/metadata.xml b/dev-perl/Math-Int64/metadata.xml
new file mode 100644
index 000000000000..1906443cfc40
--- /dev/null
+++ b/dev-perl/Math-Int64/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Math-Int64</remote-id>
+ <remote-id type="cpan-module">Math::Int64</remote-id>
+ <remote-id type="cpan-module">Math::Int64::die_on_overflow</remote-id>
+ <remote-id type="cpan-module">Math::Int64::native_if_available</remote-id>
+ <remote-id type="cpan-module">Math::UInt64</remote-id>
+ </upstream>
+</pkgmetadata>