summaryrefslogtreecommitdiff
path: root/dev-perl/Math-Int128
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-perl/Math-Int128
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-perl/Math-Int128')
-rw-r--r--dev-perl/Math-Int128/Manifest3
-rw-r--r--dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild38
-rw-r--r--dev-perl/Math-Int128/metadata.xml18
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-perl/Math-Int128/Manifest b/dev-perl/Math-Int128/Manifest
new file mode 100644
index 000000000000..61a6e58f9e6f
--- /dev/null
+++ b/dev-perl/Math-Int128/Manifest
@@ -0,0 +1,3 @@
+DIST Math-Int128-0.22.tar.gz 103698 BLAKE2B 1b23468c07c95681f7d94496edb7d0c26e7e4003b3ba74675bc0da0df1efd327e30ee88071242ffa6fa677de942c61c496eb346d00d59b27c461659a34231b46 SHA512 8384891e6a8e6e1696a7fe1d5da8c27c229e7926c6a16ac1114e812dce3a8a75f64d9d1128d2c63f17753c91c54c72dadbd3837e140624f9f1e47d462dccb74f
+EBUILD Math-Int128-0.220.0.ebuild 768 BLAKE2B 7045abb4d7709b8525fc479fad3564581af49bb8ed56ce4e511a7cf15ea0411f5b435c44606bb76b07d1be14d9ae992913c4dc2a11629d4fb3c2b9ec4aa3aaed SHA512 441965f524ba55b7014802ecef4bf2dfcae36dc9b77002c19855d1733f40d0665b947bff179922864181184293b5efb600be4210d2faf5dbf33ea43fd651eb83
+MISC metadata.xml 647 BLAKE2B aa06859609a95a98fe6a1f21ebfc11c1ce38a5ea26af457dd1509be029cec5338d06f93da7c80b280507a1b4b27ab47bd2ffd549c634700523c58eb152fc7c5a SHA512 133d9b8cc0a6bbdf4c9800e102b905aeddf3f732cfbcd9a6003dd1ea9b354a366c7196b28e35bfb94b80d176a66204037d301ee7a6b0f77bf5b6e51a1561f028
diff --git a/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild b/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
new file mode 100644
index 000000000000..693b54d44fd5
--- /dev/null
+++ b/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.22
+DIST_EXAMPLES=("benchmarks/*")
+inherit perl-module
+
+DESCRIPTION="Manipulate 128 bits integers in Perl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Exporter
+ >=dev-perl/Math-Int64-0.510.0
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Math-BigInt
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-eol.t"
+ "t/author-no-tabs.t"
+ "t/author-pod-spell.t"
+ "t/release-cpan-changes.t"
+ "t/release-pod-syntax.t"
+ "t/release-portability.t"
+ "t/release-synopsis.t"
+)
diff --git a/dev-perl/Math-Int128/metadata.xml b/dev-perl/Math-Int128/metadata.xml
new file mode 100644
index 000000000000..39c3208db96f
--- /dev/null
+++ b/dev-perl/Math-Int128/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Math-Int128</remote-id>
+ <remote-id type="cpan-module">Math::Int128</remote-id>
+ <remote-id type="cpan-module">Math::Int128::die_on_overflow</remote-id>
+ <remote-id type="cpan-module">Math::UInt128</remote-id>
+ </upstream>
+</pkgmetadata>