summaryrefslogtreecommitdiff
path: root/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild')
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild
new file mode 100644
index 000000000000..9d6b448d94bd
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=0.19
+inherit perl-module
+
+DESCRIPTION="What BigInts are before they become big"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.999.812
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"
+
+src_test() {
+ local bad_files=( "t/pod_cov.t" "t/pod.t" )
+ perl_rm_files "${bad_files[@]}"
+ perl-module_src_test
+}