summaryrefslogtreecommitdiff
path: root/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-02 21:07:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-02 21:07:25 +0000
commit27dfd272ae3be15b1017f733682211afa1c7c0f0 (patch)
tree1fe1c9ed5c5d79c63069bb8d541be075ccc3aac2 /dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
parentd950fa39dbe16d164ed0cb8e3036fd5d0d896a4c (diff)
gentoo resync : 02.11.2017
Diffstat (limited to 'dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild')
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
new file mode 100644
index 000000000000..037b684079f9
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=0.17
+inherit perl-module
+
+DESCRIPTION="What BigInts are before they become big"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.999.801
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ >=virtual/perl-Test-Simple-0.520.0
+ virtual/perl-Math-BigRat
+ )
+"
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
+src_test() {
+ local bad_files=( "t/pod_cov.t" "t/pod.t" )
+ # https://rt.cpan.org/Public/Bug/Display.html?id=75667"
+ #bad_files+=( "t/bigintpm.t" )
+ perl_rm_files "${bad_files[@]}"
+ perl-module_src_test
+}