summaryrefslogtreecommitdiff
path: root/dev-perl/Math-Base36/Math-Base36-0.140.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-perl/Math-Base36/Math-Base36-0.140.0-r1.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-perl/Math-Base36/Math-Base36-0.140.0-r1.ebuild')
-rw-r--r--dev-perl/Math-Base36/Math-Base36-0.140.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Math-Base36/Math-Base36-0.140.0-r1.ebuild b/dev-perl/Math-Base36/Math-Base36-0.140.0-r1.ebuild
new file mode 100644
index 000000000000..60da5e9569e0
--- /dev/null
+++ b/dev-perl/Math-Base36/Math-Base36-0.140.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=BRICAS
+DIST_VERSION=0.14
+inherit perl-module
+
+DESCRIPTION="Encoding and decoding of base36 strings"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-perl/Test-Exception
+ )
+"
+
+PERL_RM_FILES=( t/99-pod.t t/98-pod_coverage.t )
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install /use lib q[.];\nuse inc::Module::Install /' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}