summaryrefslogtreecommitdiff
path: root/dev-perl/Mail-IMAPClient/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-perl/Mail-IMAPClient/files
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-perl/Mail-IMAPClient/files')
-rw-r--r--dev-perl/Mail-IMAPClient/files/3.43-makefilepl.patch89
1 files changed, 89 insertions, 0 deletions
diff --git a/dev-perl/Mail-IMAPClient/files/3.43-makefilepl.patch b/dev-perl/Mail-IMAPClient/files/3.43-makefilepl.patch
new file mode 100644
index 000000000000..35990fe79c7e
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/files/3.43-makefilepl.patch
@@ -0,0 +1,89 @@
+diff -ruN Mail-IMAPClient-3.43.orig/Makefile.PL Mail-IMAPClient-3.43/Makefile.PL
+--- Mail-IMAPClient-3.43.orig/Makefile.PL 2021-02-16 17:47:10.000000000 +0100
++++ Mail-IMAPClient-3.43/Makefile.PL 2021-06-28 22:55:47.886460876 +0200
+@@ -4,39 +4,6 @@
+
+ use 5.008_001;
+
+-my @missing;
+-my %optional = (
+- "Authen::NTLM" => { for => "Authmechanism 'NTLM'" },
+- "Authen::SASL" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "Compress::Zlib" => { for => "COMPRESS DEFLATE support" },
+- "Digest::HMAC_MD5" => { for => "Authmechanism 'CRAM-MD5'" },
+- "Digest::MD5" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "IO::Socket::IP" => { for => "IPv6 support" },
+- "IO::Socket::SSL" => { for => "SSL enabled connections (Ssl => 1)" },
+- "Test::Pod" => { for => "Pod tests", ver => "1.00" },
+-);
+-
+-foreach my $mod ( sort keys %optional ) {
+- my $for = $optional{$mod}->{"for"} || "";
+- my $ver = $optional{$mod}->{"ver"} || "";
+- eval "use $mod $ver ();";
+- push @missing, $mod . ( $for ? " for $for" : "" ) if $@;
+-}
+-
+-# similar message to one used in DBI:
+-if (@missing) {
+- print( "The following optional modules were not found:",
+- map( "\n\t" . $_, @missing ), "\n" );
+-
+- print <<'MSG';
+-Optional modules are available from any CPAN mirror, reference:
+- https://metacpan.org/
+- https://www.cpan.org/modules/by-module/
+-
+-MSG
+- sleep 3;
+-}
+-
+ # HACK: die on broken Parse::RecDescent 1.966002 through 1.967009
+ # - rt.cpan.org#74593: Recent changes break Module::ExtractUse and ...
+ # - rt.cpan.org#74733: Fails with Parse::RecDescent >= 1.966_002
+@@ -92,45 +59,5 @@
+ clean => { FILES => 'test.txt' },
+ );
+
+-set_test_data();
+-
+ exit 0;
+
+-###
+-### HELPERS
+-###
+-
+-sub set_test_data {
+- unless ( -f "lib/Mail/IMAPClient.pm" ) {
+- warn("ERROR: not in installation directory\n");
+- return;
+- }
+-
+- if ( -s "./test.txt" ) {
+- print("The file test.txt will be used for extended tests.\n");
+- return;
+- }
+-
+- print <<EOF;
+-
+-(OPTIONAL) For extended tests during 'make test', create a file
+-'test.txt' in the top level directory of this distribution (the same
+-directory as the Makefile.PL, etc.). This file must contain an IMAP
+-server name or IP (server=...), a user account (user=...), and a
+-password (passed=...). A port (port=....) and an authentication
+-mechanism to be used (authmechanism=...) can also be specified.
+-
+-Example:
+-
+---- BEGIN: test.txt ---
+-server=localhost
+-user=mytestuser
+-passed=mypassword
+-port=143
+---- END: test.txt ---
+-
+-NOTE: When testing is completed, be sure to remove test.txt (either by
+-hand or by 'make clean').
+-
+-EOF
+-}