summaryrefslogtreecommitdiff
path: root/dev-perl/MIME-Lite/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/MIME-Lite/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/MIME-Lite/files')
-rw-r--r--dev-perl/MIME-Lite/files/3.030-makefilepl.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/MIME-Lite/files/3.030-makefilepl.patch b/dev-perl/MIME-Lite/files/3.030-makefilepl.patch
new file mode 100644
index 000000000000..1fea2f7f53a4
--- /dev/null
+++ b/dev-perl/MIME-Lite/files/3.030-makefilepl.patch
@@ -0,0 +1,43 @@
+diff -Naur MIME-Lite-3.030/Makefile.PL MIME-Lite-3.030.new/Makefile.PL
+--- MIME-Lite-3.030/Makefile.PL 2013-11-04 02:04:48.000000000 +0000
++++ MIME-Lite-3.030.new/Makefile.PL 2016-02-22 10:15:49.107771292 +0000
+@@ -5,39 +5,12 @@
+ #------------------------------------------------------------
+ # Makefile:
+ #------------------------------------------------------------
+-my %extra_prereq = (
+- 'Mail::Address' => 1.62,
+- 'MIME::Types' => 1.28,
+- 'MIME::Base64' => undef,
+- 'MIME::QuotedPrint' => undef,
+-);
+-
+-for my $module (sort keys %extra_prereq) {
+- local $@;
+- my $ok = eval "require $module; \$extra_prereq{\$module} && \$module->VERSION(\$extra_prereq{\$module}); 1";
+- delete $extra_prereq{ $module } if $ok;
+-}
+-
+ my %prereq = (
+ 'File::Spec' => 0,
+ 'File::Basename' => 0,
+ 'Email::Date::Format' => '1.000', # first release
+ );
+
+-if (%extra_prereq) {
+- print "MIME::Lite is designed to take advantage of a variety of external modules\n",
+- "if they are not present then MIME::Lite will attempt to do its best\n",
+- "but its strongly recommend that you install them.\n\n",
+- "These modules are:\n",
+- (map {; "\t$_\n" } sort keys %extra_prereq),
+- "I can add these modules to the prereq list which will cause the files to be\n",
+- "automatically installed if they aren't already present\n";
+-
+- if (prompt("Add prereqs?",'Yes')=~/y/i) {
+- %prereq = (%prereq, %extra_prereq);
+- }
+-}
+-
+ # Write the Makefile:
+ WriteMakefile(
+ NAME => 'MIME::Lite',