summaryrefslogtreecommitdiff
path: root/dev-perl/MIME-Lite/files/3.033-makefilepl.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-perl/MIME-Lite/files/3.033-makefilepl.patch
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-perl/MIME-Lite/files/3.033-makefilepl.patch')
-rw-r--r--dev-perl/MIME-Lite/files/3.033-makefilepl.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/MIME-Lite/files/3.033-makefilepl.patch b/dev-perl/MIME-Lite/files/3.033-makefilepl.patch
new file mode 100644
index 000000000000..3a1c6527a74a
--- /dev/null
+++ b/dev-perl/MIME-Lite/files/3.033-makefilepl.patch
@@ -0,0 +1,43 @@
+diff -ruN MIME-Lite-3.033.orig/Makefile.PL MIME-Lite-3.033/Makefile.PL
+--- MIME-Lite-3.033.orig/Makefile.PL 2021-05-30 00:02:41.000000000 +0200
++++ MIME-Lite-3.033/Makefile.PL 2021-07-04 18:17:45.413495198 +0200
+@@ -6,39 +6,12 @@
+ #------------------------------------------------------------
+ # Makefile:
+ #------------------------------------------------------------
+-my %extra_prereq = (
+- 'Mail::Address' => 1.62,
+- 'MIME::Types' => 1.28,
+- 'MIME::Base64' => 0,
+- 'MIME::QuotedPrint' => 0,
+-);
+-
+ my %prereq = (
+ 'File::Spec' => 0,
+ 'File::Basename' => 0,
+ 'Email::Date::Format' => '1.000', # first release
+ );
+
+-for my $module (sort keys %extra_prereq) {
+- local $@;
+- my $ok = eval "require $module; \$extra_prereq{\$module} && \$module->VERSION(\$extra_prereq{\$module}); 1";
+- $prereq{ $module } = delete $extra_prereq{ $module } if $ok;
+-}
+-
+-if (%extra_prereq) {
+- print "MIME::Lite is designed to take advantage of a variety of external modules\n",
+- "if they are not present then MIME::Lite will attempt to do its best\n",
+- "but its strongly recommend that you install them.\n\n",
+- "These modules are:\n",
+- (map {; "\t$_\n" } sort keys %extra_prereq),
+- "I can add these modules to the prereq list which will cause the files to be\n",
+- "automatically installed if they aren't already present\n";
+-
+- if (prompt("Add prereqs?",'Yes')=~/y/i) {
+- %prereq = (%prereq, %extra_prereq);
+- }
+-}
+-
+ # Write the Makefile:
+ WriteMakefile(
+ NAME => 'MIME::Lite',