summaryrefslogtreecommitdiff
path: root/dev-perl/List-MoreUtils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/List-MoreUtils
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/List-MoreUtils')
-rw-r--r--dev-perl/List-MoreUtils/List-MoreUtils-0.418.0.ebuild23
-rw-r--r--dev-perl/List-MoreUtils/List-MoreUtils-0.419.0.ebuild23
-rw-r--r--dev-perl/List-MoreUtils/List-MoreUtils-0.426.0.ebuild28
-rw-r--r--dev-perl/List-MoreUtils/Manifest8
-rw-r--r--dev-perl/List-MoreUtils/files/List-MoreUtils-0.426.0-xs-config.patch78
-rw-r--r--dev-perl/List-MoreUtils/metadata.xml16
6 files changed, 176 insertions, 0 deletions
diff --git a/dev-perl/List-MoreUtils/List-MoreUtils-0.418.0.ebuild b/dev-perl/List-MoreUtils/List-MoreUtils-0.418.0.ebuild
new file mode 100644
index 000000000000..5e0d909257e7
--- /dev/null
+++ b/dev-perl/List-MoreUtils/List-MoreUtils-0.418.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=REHSACK
+DIST_VERSION=0.418
+inherit perl-module
+
+DESCRIPTION="Provide the missing functionality from List::Util"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test +xs"
+# See MoreUtils.pm/LICENSE
+LICENSE="Apache-2.0 || ( Artistic GPL-1+ )"
+
+PDEPEND="xs? ( dev-perl/List-MoreUtils-XS )"
+RDEPEND=">=dev-perl/Exporter-Tiny-0.38.0"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.960.0 )
+"
diff --git a/dev-perl/List-MoreUtils/List-MoreUtils-0.419.0.ebuild b/dev-perl/List-MoreUtils/List-MoreUtils-0.419.0.ebuild
new file mode 100644
index 000000000000..a90464b5d314
--- /dev/null
+++ b/dev-perl/List-MoreUtils/List-MoreUtils-0.419.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=REHSACK
+DIST_VERSION=0.419
+inherit perl-module
+
+DESCRIPTION="Provide the missing functionality from List::Util"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test +xs"
+# See MoreUtils.pm/LICENSE
+LICENSE="Apache-2.0 || ( Artistic GPL-1+ )"
+
+PDEPEND="xs? ( dev-perl/List-MoreUtils-XS )"
+RDEPEND=">=dev-perl/Exporter-Tiny-0.38.0"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.960.0 )
+"
diff --git a/dev-perl/List-MoreUtils/List-MoreUtils-0.426.0.ebuild b/dev-perl/List-MoreUtils/List-MoreUtils-0.426.0.ebuild
new file mode 100644
index 000000000000..e6a2840d94dd
--- /dev/null
+++ b/dev-perl/List-MoreUtils/List-MoreUtils-0.426.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=REHSACK
+DIST_VERSION=0.426
+inherit perl-module
+
+DESCRIPTION="Provide the missing functionality from List::Util"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test +xs"
+# See MoreUtils.pm/LICENSE
+LICENSE="Apache-2.0 || ( Artistic GPL-1+ )"
+
+PDEPEND="xs? ( >=dev-perl/List-MoreUtils-XS-0.426.0 )"
+RDEPEND=">=dev-perl/Exporter-Tiny-0.38.0"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.960.0 )
+"
+PATCHES=("${FILESDIR}/${P}-xs-config.patch")
+src_configure() {
+ export LMU_USE_XS="$(usex xs 1 0)"
+ perl-module_src_configure
+}
diff --git a/dev-perl/List-MoreUtils/Manifest b/dev-perl/List-MoreUtils/Manifest
new file mode 100644
index 000000000000..803ea6d3ec1e
--- /dev/null
+++ b/dev-perl/List-MoreUtils/Manifest
@@ -0,0 +1,8 @@
+AUX List-MoreUtils-0.426.0-xs-config.patch 2181 BLAKE2B dea4017e432a3c3bba4cc3d336bb6d9f47bd657b78265e92a2b80ab38619a8e7205f3771d2fecbef164d4eaae3bbc387e73f3fd1f3ef0f364a9b4ff9f7d5cac9 SHA512 e1a0c15d2835871b2e52a069d8c99cfee74da58251907c2519146b8e8b2fbdd1863a93aa1b623cf4ffc100ebe29605f8dda0415b1969707eec3bb1ca414d482d
+DIST List-MoreUtils-0.418.tar.gz 55111 BLAKE2B 7c24aaec6293c6bb4f7f5a5b6511944aac6c75dd826895f56ae2719bdf3c5f19381583574b9ae048c8f99e6da4d8d6f58e7df45fee9d843aa831db16a2eec8de SHA512 7ba4395262c4406e822baf40e5a32aa6d93779a56d2567c4920f085ab2580c376db41e2141e4b9b43860d65122ebe73a03dfb0ed76a32f087b05ca7eb90f6d6e
+DIST List-MoreUtils-0.419.tar.gz 55193 BLAKE2B aa31d5a4abd28efc8c71877b0267b847ede645fef9889d639982292187a813384a58c361ca2d7513947161d581735b23301f36a058f21e02ad7cdfce65264402 SHA512 d13beb5031d1559c2ec4cb93826e86f0f314c4f10c4fdcac6910de0cb039199599911838eadd499e81cb41025aae2a52d69a259653a9637679a1705c7adcd37a
+DIST List-MoreUtils-0.426.tar.gz 145518 BLAKE2B 773e0a78147a4d62ad61493cbe8d4c40569d7a2be1754e11f85cbfb57b10d411c3d25445607b10429031f40ac58b3d1b0a2e5d011e556d21e8fba5f1bd7fde2b SHA512 622ce2e5e418ba803359107b15cc9f5234bfbb32f03d072c0b448b6b8d603472254d9653757d0048f537852a68b17bef1b71a7f5104d95802e4b78f595664b32
+EBUILD List-MoreUtils-0.418.0.ebuild 727 BLAKE2B 0c6a233e0a06cc0c668c553504b6a2071ed49df61b615aa72e60b2c393fdb91469e0d78aa90a7a91086a208c2ea485597443ac8f7e967cb40e845fcc463ee750 SHA512 33fb12ecdc5b870fbe5f796bd96e5d9598b1dbcc51b84bf8b05c90353049d5e1e710d3e37872cfb007c754948276a410697db5f6bc9c7aef02e1c22b181913a8
+EBUILD List-MoreUtils-0.419.0.ebuild 736 BLAKE2B 5af382688fd14681472f89cbd0641fc4ff640503583071ac828eadc398ed7e11781bd82c9dc965b05066c9ff7d4d918de3a3ab8a84bbe5cb11794f8978666a9d SHA512 b9a2dd380767a3d4033794aef12506588659ab5a2883d8989757527a15be4671f0e3042147f232c8274353cc77d1f5b79edb4def8c7da5bd32dadc9e8f277742
+EBUILD List-MoreUtils-0.426.0.ebuild 874 BLAKE2B 8bb94eb9706d27fd58aeb371e31789b3bc1a315ff464162878b11f62014ddd1bcaf8202b7582fb9f2e9024a5fd2527e50e318b189d41a5a95245fba05e3ea278 SHA512 29b1c47ad0b3a17b39cb1d1e54ff8ce6b5056a9c29f6aa18b0ac22e23a97632d735e7df560c335466182deaca91932b923716f9acaefbdbbe83d5d6010d02636
+MISC metadata.xml 565 BLAKE2B 1d9445527a6329e96a6d38f590f02fa98710bbf649ec5709533b5212402b7beaa4fb9211fe93814de01054a4bdf7c89ea52e8e0f6ee625ffd50f367b2c6286aa SHA512 b4fc48156533446dd91d18f6aac2dd58a61f3e3911357930b3710241f8b3e29a7a9143b02bf348e25c15e5cb323c66dbaf6b3555d64b5b333bc7281bded865be
diff --git a/dev-perl/List-MoreUtils/files/List-MoreUtils-0.426.0-xs-config.patch b/dev-perl/List-MoreUtils/files/List-MoreUtils-0.426.0-xs-config.patch
new file mode 100644
index 000000000000..941f2d6bc1a1
--- /dev/null
+++ b/dev-perl/List-MoreUtils/files/List-MoreUtils-0.426.0-xs-config.patch
@@ -0,0 +1,78 @@
+From 903ed372cad330e86ef767eb98a4d29d04781e5e Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 28 Oct 2017 14:53:23 +1300
+Subject: Use configuration instead of pure discovery for XS Support
+
+Given in Gentoo that ::XS is either going to be available, or not,
+based on user configuration, *before* configure runs, trying to turn
+it on/off in configure is nonsense.
+
+Subsequently, this test logic just determines if we should be running
+the XS tests or not.
+
+If ::XS is installed already, then XS tests should be run despite user
+not opting in to XS, as the opt-in only regulates dependencies, but
+LMU can still trigger ::XS at runtime.
+
+If the user opts in to XS, then the tests should be run regardless of
+perl detecting XS being installed, because XS *NOT* being available
+is then an error.
+---
+ Makefile.PL | 41 ++---------------------------------------
+ 1 file changed, 2 insertions(+), 39 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 89680b1..5083b86 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -8,45 +8,8 @@ use 5.008_001;
+ use Config;
+ use ExtUtils::MakeMaker;
+
+-BEGIN
+-{
+- unless (grep { $_ eq "." } @INC)
+- {
+- use lib ".";
+- }
+-}
+-
+-use inc::latest 'Capture::Tiny';
+-use inc::latest 'Config::AutoConf';
+-
+-if (inc::latest->can("write"))
+-{
+- inc::latest->write("inc");
+- for my $mod (inc::latest->loaded_modules)
+- {
+- inc::latest->bundle_module($mod, "inc");
+- }
+-}
+-
+-use inc::Config::AutoConf::LMU ();
+-
+-inc::Config::AutoConf::LMU->_set_argv(@ARGV); # XXX hack because we cannot construct for global use
+-my $loadable_xs = inc::Config::AutoConf::LMU->check_produce_loadable_xs_build();
+-
+-if (-d "Sandbox")
+-{
+- unless (grep { $_ eq "." } @INC)
+- {
+- use lib ".";
+- }
+- eval "use Sandbox::Tumble ();";
+- $@ and die $@;
+- eval "use File::Path ();";
+- File::Path->import;
+- -d 't/xs' and rmtree('t/xs');
+- -d 't/pureperl' and rmtree('t/pureperl');
+- Sandbox::Tumble->tumble(qw(t));
+-}
++my $loadable_xs = $ENV{LMU_USE_XS} ||
++ eval { require List::MoreUtils::XS; List::MoreUtils::XS->VERSION(0.426) };
+
+ my $conflictMsg = <<EOCM;
+ ***
+--
+2.14.3
+
diff --git a/dev-perl/List-MoreUtils/metadata.xml b/dev-perl/List-MoreUtils/metadata.xml
new file mode 100644
index 000000000000..4fa641e66c8c
--- /dev/null
+++ b/dev-perl/List-MoreUtils/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <use>
+ <flag name="xs">Install C-Based backend implementation for performance</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpan">List-MoreUtils</remote-id>
+ <remote-id type="cpan-module">List::MoreUtils</remote-id>
+ <remote-id type="cpan-module">List::MoreUtils::PP</remote-id>
+ </upstream>
+</pkgmetadata>