summaryrefslogtreecommitdiff
path: root/dev-perl/Lchown/Lchown-1.10.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-perl/Lchown/Lchown-1.10.0-r3.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-perl/Lchown/Lchown-1.10.0-r3.ebuild')
-rw-r--r--dev-perl/Lchown/Lchown-1.10.0-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Lchown/Lchown-1.10.0-r3.ebuild b/dev-perl/Lchown/Lchown-1.10.0-r3.ebuild
new file mode 100644
index 000000000000..4dea86353d7f
--- /dev/null
+++ b/dev-perl/Lchown/Lchown-1.10.0-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=NCLEATON
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Use the lchown(2) system call from Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-perl/Module-Build"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+"
+PERL_RM_FILES=(
+ t/pod-coverage.t
+ t/pod.t
+)
+src_configure() {
+ unset LD
+ [[ -n "${CCLD}" ]] && export LD="${CCLD}"
+ perl-module_src_configure
+}
+src_compile() {
+ ./Build --config optimize="${CFLAGS}" build || die
+}