summaryrefslogtreecommitdiff
path: root/dev-perl/LaTeX-Driver/LaTeX-Driver-0.300.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /dev-perl/LaTeX-Driver/LaTeX-Driver-0.300.2.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'dev-perl/LaTeX-Driver/LaTeX-Driver-0.300.2.ebuild')
-rw-r--r--dev-perl/LaTeX-Driver/LaTeX-Driver-0.300.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/LaTeX-Driver/LaTeX-Driver-0.300.2.ebuild b/dev-perl/LaTeX-Driver/LaTeX-Driver-0.300.2.ebuild
new file mode 100644
index 000000000000..dcecf72ede33
--- /dev/null
+++ b/dev-perl/LaTeX-Driver/LaTeX-Driver-0.300.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=EINHVERFR
+DIST_VERSION=0.300.2
+inherit perl-module
+
+DESCRIPTION="Perl encapsulation of invoking the Latex programs"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Capture-Tiny
+ dev-perl/Class-Accessor
+ dev-perl/Exception-Class
+ dev-perl/File-Slurp
+ virtual/perl-File-Spec
+ dev-perl/File-pushd
+ virtual/perl-Getopt-Long
+ dev-perl/Readonly
+ virtual/perl-parent
+ virtual/latex-base
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Exception
+ app-text/texlive-core
+ dev-texlive/texlive-latexextra
+ )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+
+ use test && perl_rm_files t/{90-kwalitee,91-pod,92-pod-coverage,93-perl-critic}.t
+
+ perl-module_src_prepare
+}