summaryrefslogtreecommitdiff
path: root/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild')
-rw-r--r--dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild b/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild
new file mode 100644
index 000000000000..f6efc4943fbc
--- /dev/null
+++ b/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=6.07
+inherit perl-module
+
+DESCRIPTION="Provide https support for LWP::UserAgent"
+
+SLOT="0"
+IUSE="test"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-misc/ca-certificates
+ >=dev-perl/IO-Socket-SSL-1.540.0
+ >=dev-perl/libwww-perl-6.60.0
+ >=dev-perl/Net-HTTP-6
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-RequiresInternet
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.70.0-etcsslcerts.patch
+ "${FILESDIR}"/${PN}-6.70.0-CVE-2014-3230.patch # note: breaks a test, still needed?
+)
+PERL_RM_FILES=(
+ "t/https_proxy.t" # see above
+)