summaryrefslogtreecommitdiff
path: root/dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild')
-rw-r--r--dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild b/dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild
new file mode 100644
index 000000000000..ce475ee87dc8
--- /dev/null
+++ b/dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.08
+inherit perl-module
+
+DESCRIPTION="Does your process have access to the web"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+# https://rt.cpan.org/Public/Bug/Display.html?id=112728
+PATCHES=("${FILESDIR}/${DIST_VERSION}-no-network.patch")
+
+# LWP::Simple -> libwww-perl
+RDEPEND="
+ >=dev-perl/libwww-perl-5.805.0
+ >=dev-perl/URI-1.350.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? ( >=virtual/perl-Test-Simple-0.420.0 )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install::DSL 1\.01;/use lib q[.];\nuse inc::Module::Install::DSL 1.01;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}