summaryrefslogtreecommitdiff
path: root/dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild')
-rw-r--r--dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild b/dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild
new file mode 100644
index 000000000000..2e220e3310e8
--- /dev/null
+++ b/dev-perl/JSON-XS/JSON-XS-3.40.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=3.04
+DIST_EXAMPLES=("eg/bench")
+inherit perl-module
+
+DESCRIPTION="JSON::XS - JSON serialising/deserialising, done correctly and fast"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Types-Serialiser
+ dev-perl/common-sense
+ !<dev-perl/JSON-2.900.0
+ !<dev-perl/JSON-Any-1.310.0
+"
+DEPEND="${RDEPEND}
+ dev-perl/Canary-Stability
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+ test? ( virtual/perl-Test-Harness )"