summaryrefslogtreecommitdiff
path: root/dev-perl/Inline-Python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Inline-Python
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Inline-Python')
-rw-r--r--dev-perl/Inline-Python/Inline-Python-0.520.0.ebuild37
-rw-r--r--dev-perl/Inline-Python/Manifest6
-rw-r--r--dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch20
-rw-r--r--dev-perl/Inline-Python/metadata.xml15
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-perl/Inline-Python/Inline-Python-0.520.0.ebuild b/dev-perl/Inline-Python/Inline-Python-0.520.0.ebuild
new file mode 100644
index 000000000000..dab6c4878622
--- /dev/null
+++ b/dev-perl/Inline-Python/Inline-Python-0.520.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+# Feel free to add more targets after testing.
+
+DIST_AUTHOR=NINE
+DIST_VERSION=0.52
+inherit python-single-r1 perl-module
+
+DESCRIPTION="Easy implementation of Python extensions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ >=virtual/perl-Digest-MD5-2.500.0
+ >=dev-perl/Inline-0.460.0
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Proc-ProcessTable-0.530.0
+ virtual/perl-Test-Simple
+ dev-perl/Test-Deep
+ virtual/perl-Test
+ )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.460.0-insanepython.patch" )
diff --git a/dev-perl/Inline-Python/Manifest b/dev-perl/Inline-Python/Manifest
new file mode 100644
index 000000000000..9bf6ef49ca45
--- /dev/null
+++ b/dev-perl/Inline-Python/Manifest
@@ -0,0 +1,6 @@
+AUX Inline-Python-0.460.0-insanepython.patch 652 SHA256 acdd514e011d68e8a4cf76aa7a213fe06efc40955654f7573487d18d45fb819b SHA512 f9fc8e8a287801f331ac92bdbd80f665648f9fee8dc43383fe563c6ca8e0aa4d01e06b09a25408b7908e5394cb4bf496e76441c6ee5dbf0fdb7c65dc4222bac1 WHIRLPOOL 7e2c00ad20e962a7142a3c01fd0e57de4fe663b24576d57298ac00d8a2f5de0726a5f3f4cc66393531e47387788357f15b608e7f18db20671189af92c526f659
+DIST Inline-Python-0.52.tar.gz 57345 SHA256 9c946e1c9ac308d4431f07bbd3965a945850d69eab33aced6c81e674729e2ff4 SHA512 5b097740e149ae5a1a51d068f2732bff06daa03279ea3ad009b34fc72f0baccf0304989a3b9c3d9b8cadca1bb897693d48fb1a91ed3dc412c61463256a9bcaaa WHIRLPOOL ab2114881997791226b4e9005cc3d7daec553c21b0f595945abb941638b64ff85b31692c3c882edc523603c167e9dee16c8e75f5f84b8759a6f1d525b3f8755a
+EBUILD Inline-Python-0.520.0.ebuild 771 SHA256 09f1e30b804b5c49bcdd7464c3493f0f7ec4503c547fd7b3c52970513e885180 SHA512 7090643beaa27f26135312cd199d11353045a5c5194ba14d82bb71b12138456622aaa336df7554ae39cdecbf2ae0c386b690eae1efce75c9951980db8ed8abfe WHIRLPOOL 5eed649e3fa7e17fb2adc4e12253feeb5927a52f8281cec08bffee68d3cd662d362e037e519ea647fae50d1978df5f74b78ea128da4b2a8ecf866d43551f1a98
+MISC ChangeLog 3224 SHA256 46c7062392a618007cf7732af36b3ab4077b46be2b429cda8c45a52b1d1b991a SHA512 590067d247b87c61a554b04d9317a7b9821e43ea4fb06fce7da9ac97d4c8bedec128b5a89e287ce7122c765fb2227b59b09790248f41a0cc237d31eb4e39bf8a WHIRLPOOL 79221a4a341dea54f833e2b73145e88f8ac286953d83acc1526bf3cd28bc36542565d003cd6fb771f385042a5e6c29c78281a2fc6333a50ad0680159b1c5fb85
+MISC ChangeLog-2015 4395 SHA256 b69a478fb9bc2603c4f0cf0f362004474f034b1a97ad789236ef1b459fde2e9b SHA512 3139fd122ca0ffef4c43a8a4133ba04f3c3963f3abac26e73c362a3ffe2bafd75ed641e293deaf2c1c93ef0319b10867fbe7f6d8d7a0719dbf16ad485cf0b298 WHIRLPOOL 24dbaaca8cd8c361c5e771fb3dabc10c93018b144eaa4f176a4f79fe37387612b79feba7f1ef9c5c5baf82ad9eaa03d32fdfebce34172596d0e378e57b5abfbb
+MISC metadata.xml 613 SHA256 4f4943e94bd6bcf8337fa7b6f819d947f14d90e396a8fcd9fad6de9afe357df0 SHA512 83bd0994320a23ef4e166daa325860f732f3f820dc614bc7ae3222847971e45a0a1fc9a9ef6bdf002efb48911ea1a27c27309e16399d0ec60bde4cef131b6a1f WHIRLPOOL 3df43cd6d693a0bb0bfac015f21fddd4e1ff95943182437cf456de2fdd634263ffbdaa11863f8003d56bcbb4f1d906c8890e50f3e39e9a6ef7b2cf6cd34d5ecd
diff --git a/dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch b/dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch
new file mode 100644
index 000000000000..b713f170abe8
--- /dev/null
+++ b/dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch
@@ -0,0 +1,20 @@
+diff -ruN Inline-Python-0.46.orig/Makefile.PL Inline-Python-0.46/Makefile.PL
+--- Inline-Python-0.46.orig/Makefile.PL 2014-12-07 12:35:25.478476508 +0100
++++ Inline-Python-0.46/Makefile.PL 2014-12-11 00:37:37.580577317 +0100
+@@ -134,7 +134,7 @@
+ $ref->{libpath} = join '/', (get_config_var($ref, "LIBDEST"),
+ 'config')
+ if ($ref->{libpath} eq 'None');
+- return query_options($ref) unless sanity_check($ref);
++ return $ref;
+ }
+
+ sub test_interrogate {
+@@ -171,6 +171,7 @@
+ Extra Libs: $sel->{syslibs}
+ Python Library: $sel->{libpath}/$sel->{libpython}
+ Include Path: $sel->{incpath}
++
+ END
+ # ' stupid vim.
+ }
diff --git a/dev-perl/Inline-Python/metadata.xml b/dev-perl/Inline-Python/metadata.xml
new file mode 100644
index 000000000000..b1f32aff849d
--- /dev/null
+++ b/dev-perl/Inline-Python/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Inline-Python</remote-id>
+ <remote-id type="cpan-module">Inline::Python</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Function</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Object</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Object::Data</remote-id>
+ </upstream>
+</pkgmetadata>