summaryrefslogtreecommitdiff
path: root/dev-perl/IO-Tty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /dev-perl/IO-Tty
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'dev-perl/IO-Tty')
-rw-r--r--dev-perl/IO-Tty/IO-Tty-1.160.0-r1.ebuild17
-rw-r--r--dev-perl/IO-Tty/Manifest2
-rw-r--r--dev-perl/IO-Tty/files/IO-Tty-1.160.0-musl-strlcpy.patch38
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-perl/IO-Tty/IO-Tty-1.160.0-r1.ebuild b/dev-perl/IO-Tty/IO-Tty-1.160.0-r1.ebuild
new file mode 100644
index 000000000000..296c1a886940
--- /dev/null
+++ b/dev-perl/IO-Tty/IO-Tty-1.160.0-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TODDR
+DIST_VERSION=1.16
+inherit perl-module
+
+DESCRIPTION="IO::Tty and IO::Pty modules for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.160.0-musl-strlcpy.patch
+)
diff --git a/dev-perl/IO-Tty/Manifest b/dev-perl/IO-Tty/Manifest
index ff9156ac3700..c5231ab0e7a1 100644
--- a/dev-perl/IO-Tty/Manifest
+++ b/dev-perl/IO-Tty/Manifest
@@ -1,3 +1,5 @@
+AUX IO-Tty-1.160.0-musl-strlcpy.patch 1468 BLAKE2B 1021fb5982c3f99859d299a08606ac0e1f94d73a48173d81e062342c6cc0e8fb6e129bd10438a459913ffee5389dad4ad0dacfd6a36947c5c536421c6fbca274 SHA512 a40ad0735dda22568b6be74e4a5cabb54e2943b5e357a536bdb9f848861d44b468e812010224cb22d0aeacbe778be07cd60310ca548ad91735784052fa47d100
DIST IO-Tty-1.16.tar.gz 26765 BLAKE2B 94de85df09ac717e36b2c9e469e6cbd707cc7c9c92eb1be729373856af944a2664fbc913441151e7b417ae6b5c1d62cbda4416e407e4849c1ac34181460efe11 SHA512 a6f28a8796992645c4b2ddab5b3a76f49e61a891442078ef8249088d077108ea63bb4c8000cf39d15d13801b82e1cfcbe6ea0e6542789ab28385d83e03f6a9de
+EBUILD IO-Tty-1.160.0-r1.ebuild 495 BLAKE2B e813cb1fa59b4be36e875640f99900c2c571e8a841d59cf4e499ee0eba5ec593bc19923c8013c90266b0412ece500b35fb5aca51ce4f7e6047bff04710a2e2b1 SHA512 8b8fd1de8a827824683efbf2a549c023deb0e2728dbb7bc263b4001ec52b68bf311a8e5c5393c36fa821b765b63e28af3f42d796d31ada432210438069ce6c2f
EBUILD IO-Tty-1.160.0.ebuild 426 BLAKE2B 300be9f578599aa609d0accf1806d57ccf3967bb68b575168c67f604d681f4889c7720fcbb60a57839c2f3f137ea08a3383c2b26fea8c00c34cd86831da05947 SHA512 7fe7e0f5b5f609e3d5291b300b89c6c3a0d1f382558c65f94a9c29f1932ba2563d9085cd65f27009b8678fdd34acbb45edbde1e4af6d3666482ebf0e0d20a2a0
MISC metadata.xml 439 BLAKE2B 3a82f8fe7fd4965968a3377339834afcab56ee0c4fc2764ba639c503045934efcf41cbb686a9a4dea2cd8352c4dc44b6d8365da9fdd3d50e41bb22f0c4a2e4c0 SHA512 a404c28f32c4250d8969ec62c4bcf78c94fbf90d0911b833d46636aa045af5bb1a0a4f6e4ceb0fcebb1609b7fcb4ffcb6817a77634ec3b950fdd410abccd1412
diff --git a/dev-perl/IO-Tty/files/IO-Tty-1.160.0-musl-strlcpy.patch b/dev-perl/IO-Tty/files/IO-Tty-1.160.0-musl-strlcpy.patch
new file mode 100644
index 000000000000..d96e5afe378b
--- /dev/null
+++ b/dev-perl/IO-Tty/files/IO-Tty-1.160.0-musl-strlcpy.patch
@@ -0,0 +1,38 @@
+https://github.com/toddr/IO-Tty/pull/33
+
+From fae771aefc593a0ef798bc0c1e21b0524eb85e2d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 31 Aug 2022 20:32:35 -0700
+Subject: [PATCH] Tty.xs: Do not mark strlcpy as static
+
+Some libcs e.g. musl do not provide implementation of strlcpy but they
+do provide the signature in string.h, if we mark it static here then it
+conflicts with the libc define and compiler may warn/error
+
+Fixes
+Tty.xs:190:1: error: static declaration of 'strlcpy' follows non-static declaration
+strlcpy( ^
+/mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux-musl/libio-pty-perl/1.16-r0/recipe-sysroot/usr/include/string.h:86:8: note: previous declaration is here
+size_t strlcpy (char *, const char *, size_t); ^
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/Tty.xs
++++ b/Tty.xs
+@@ -186,11 +186,11 @@ mysignal(int sig, mysig_t act)
+ * will be copied. Always NUL terminates (unless siz == 0).
+ * Returns strlen(src); if retval >= siz, truncation occurred.
+ */
+-static size_t
+-strlcpy(dst, src, siz)
+- char *dst;
+- const char *src;
+- size_t siz;
++size_t
++strlcpy(
++ char *dst,
++ const char *src,
++ size_t siz)
+ {
+ register char *d = dst;
+ register const char *s = src;
+