summaryrefslogtreecommitdiff
path: root/dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild')
-rw-r--r--dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild b/dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild
new file mode 100644
index 000000000000..3f3607ad9cfb
--- /dev/null
+++ b/dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=2.72
+inherit perl-module
+
+DESCRIPTION="Work with IO sockets in ipv6"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-perl/Socket6"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build"
+
+src_test() {
+ local BADTESTS=(
+ t/pod-coverage.t
+ t/pod.t
+ t/style-trailing-space.t
+ )
+ perl_rm_files "${BADTESTS[@]}"
+ perl-module_src_test
+}