summaryrefslogtreecommitdiff
path: root/dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0-r1.ebuild
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0-r1.ebuild')
-rw-r--r--dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0-r1.ebuild b/dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0-r1.ebuild
new file mode 100644
index 000000000000..e725afec1564
--- /dev/null
+++ b/dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MATTIASH
+DIST_VERSION=1.4
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Cache the result of http get-requests persistently"
+
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ia64 ppc sparc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-perl/libwww-perl
+ virtual/perl-Digest-MD5
+ virtual/perl-Storable
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-RequiresInternet
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/pod.t t/pod-coverage.t
+ perl-module_src_test
+}