summaryrefslogtreecommitdiff
path: root/dev-perl/HTML-TableContentParser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-perl/HTML-TableContentParser
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/HTML-TableContentParser')
-rw-r--r--dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.130.0.ebuild20
-rw-r--r--dev-perl/HTML-TableContentParser/Manifest4
-rw-r--r--dev-perl/HTML-TableContentParser/files/0.13-test.patch74
-rw-r--r--dev-perl/HTML-TableContentParser/metadata.xml16
4 files changed, 0 insertions, 114 deletions
diff --git a/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.130.0.ebuild b/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.130.0.ebuild
deleted file mode 100644
index 642f69822aaa..000000000000
--- a/dev-perl/HTML-TableContentParser/HTML-TableContentParser-0.130.0.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MODULE_AUTHOR=SDRABBLE
-MODULE_VERSION=0.13
-inherit perl-module
-
-DESCRIPTION="Parse the content of tables in HTML"
-
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE=""
-
-RDEPEND="dev-perl/HTML-Parser"
-DEPEND="${RDEPEND}"
-
-SRC_TEST=do
-PATCHES=( "${FILESDIR}"/0.13-test.patch )
diff --git a/dev-perl/HTML-TableContentParser/Manifest b/dev-perl/HTML-TableContentParser/Manifest
deleted file mode 100644
index 71f5c599d232..000000000000
--- a/dev-perl/HTML-TableContentParser/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX 0.13-test.patch 2076 BLAKE2B 4b3e46ada5bc7e3a9c7f6b105bbf804083abcd4d3c1873ee894468bf2ac49aa089b78583c061c83a34d37149a165efc85db0a40ea5b537e1455763a58abc5cad SHA512 39037bc38e5bd95f710dbfe005b05f2a355fa075b3f6de3681e6fc812e18850f9ab727ec9012761c6167b35302462223f4d2543dce6135ba63320b0751600bf9
-DIST HTML-TableContentParser-0.13.tar.gz 4664 BLAKE2B 062dc7ac6a78ec75f7d306649710ef470c6b6f750f651cc976d9f44fa40fbf247a89e0847ed8a991cecd929f3ea328bbee69c2cb29627f6d4fb0e23d3a3ab5c5 SHA512 0707a0059a7d885052615ee7badecc8915d5f8c67fd8683a226e23a0690f1872519475c32f51f299333c3208c20ea15380624fd0ebd1dc0b11457febfb3db585
-EBUILD HTML-TableContentParser-0.130.0.ebuild 377 BLAKE2B b1b2a33a0751dc88124ce78bc75c603fcf91de3c21bbbdc74bc209d8a4d1db7cef3f19866fe893b74c7a44ad080923759065a17afbb53ac55e4132ffe9a0885b SHA512 c318fb523b0a654ea8ab89dcb2e9c36bba77365843f6d3b1479397dd9f3e0ec136a36483a3cdb26e2625919ce39fac273d0e674d336d101705e8fe2c41811b9f
-MISC metadata.xml 534 BLAKE2B 8407660decf17098cda6bae4fbd878ee6454f09ac54ba47c51fbf853ecee0ad7bd37dda922c771629fe59393bfb76f859b9419372e75b2c9cbe1f46fd47e2424 SHA512 8afdcb73c8dc04924721658d39ec4d853f3a96501d8e5a0998270890ce33db877328bb4520839ed5a354a72793d26e8f944127bd48fa28ba68e290f52f827c99
diff --git a/dev-perl/HTML-TableContentParser/files/0.13-test.patch b/dev-perl/HTML-TableContentParser/files/0.13-test.patch
deleted file mode 100644
index 79916acc1e1c..000000000000
--- a/dev-perl/HTML-TableContentParser/files/0.13-test.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- t/1.t
-+++ t/1.t
-@@ -2,6 +2,8 @@
-
-
- use Test;
-+use strict;
-+use warnings;
-
- BEGIN { plan tests => 34 }
-
-@@ -20,7 +22,7 @@
-
- ## Test object creation
-
--$obj = HTML::TableContentParser->new();
-+my $obj = HTML::TableContentParser->new();
- ok(defined $obj, 1, $@);
-
-
-@@ -29,14 +31,14 @@
- ## the correct values to the callback.
-
-
--$table_caption = 'This is a caption';
--$table_content1 = 'This is table cell content 1';
--$table_content2 = 'This is table cell content 2';
--$table_content3 = '<a href="SomeLink">This is table cell content 3, a link</a>';
--$table_content4 = 'Some more text wrapping <a href="SomeLink">This is table cell content 4</a> a link.';
--$header_text = 'Header text';
-+my $table_caption = 'This is a caption';
-+my $table_content1 = 'This is table cell content 1';
-+my $table_content2 = 'This is table cell content 2';
-+my $table_content3 = '<a href="SomeLink">This is table cell content 3, a link</a>';
-+my $table_content4 = 'Some more text wrapping <a href="SomeLink">This is table cell content 4</a> a link.';
-+my $header_text = 'Header text';
-
--$html = qq{
-+my $html = qq{
- <html>
- <head>
- </head>
-@@ -59,7 +61,7 @@
-
-
- $HTML::TableContentParser::DEBUG = 0;
--$tables = $obj->parse($html);
-+my $tables = $obj->parse($html);
- ok($tables->[0]->{caption}->{data}, $table_caption, $@);
- ok($tables->[0]->{rows}->[0]->{cells}->[0]->{data}, $table_content1, $@);
- ok($tables->[0]->{rows}->[1]->{cells}->[0]->{data}, $table_content2, $@);
-@@ -124,16 +126,17 @@
- ok(@$tables, 2, @_);
-
- ## and three headers for each table
--for $t (0..$#{@$tables}) {
-- for (0..$#hdrs) {
-- ok($tables->[$t]->{headers}->[$_]->{data}, $hdrs[$_], $@);
-+for my $t (0..(@$tables-1)) {
-+ for (0..2) {
-+ # ok($t, $t);
-+ ok($tables->[$t]->{headers}->[$_]->{data}, $hdrs[$_], $@);
- }
- }
-
-
- ## and three rows of three cells each, for each table.. (18 total).
--for $t (0..$#{@$tables}) {
-- for $r (0..$#rows) {
-+for my $t (0..1) {
-+ for my $r (0..$#rows) {
- for (0..2) {
- ok($tables->[$t]->{rows}->[$r]->{cells}->[$_]->{data}, $rows[$r]->[$_], $@);
- }
diff --git a/dev-perl/HTML-TableContentParser/metadata.xml b/dev-perl/HTML-TableContentParser/metadata.xml
deleted file mode 100644
index 7ee48c34292c..000000000000
--- a/dev-perl/HTML-TableContentParser/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>vdr@gentoo.org</email>
- <name>Gentoo VDR Project</name>
- </maintainer>
- <maintainer type="project">
- <email>perl@gentoo.org</email>
- <name>Gentoo Perl Project</name>
- </maintainer>
- <upstream>
- <remote-id type="cpan">HTML-TableContentParser</remote-id>
- <remote-id type="cpan-module">HTML::TableContentParser</remote-id>
- </upstream>
-</pkgmetadata>