summaryrefslogtreecommitdiff
path: root/dev-perl/Gtk2-Notify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Gtk2-Notify
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Gtk2-Notify')
-rw-r--r--dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild42
-rw-r--r--dev-perl/Gtk2-Notify/Manifest4
-rw-r--r--dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch114
-rw-r--r--dev-perl/Gtk2-Notify/metadata.xml12
4 files changed, 172 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
new file mode 100644
index 000000000000..29f1002f5e8f
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=FLORA
+DIST_VERSION=0.05
+inherit perl-module virtualx
+
+DESCRIPTION="A perl interface to the notification library"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/glib-perl
+ dev-perl/Gtk2
+ >=x11-libs/libnotify-0.7
+"
+DEPEND="${RDEPEND}
+ dev-perl/ExtUtils-Depends
+ dev-perl/ExtUtils-PkgConfig
+ test? ( dev-perl/Test-Exception )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.05-libnotify.patch )
+
+PERL_RM_FILES=( t/notification.t )
+# the test dies if no notification daemon is present...
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
+
+src_test() {
+ # bug 416729
+ virtx perl-module_src_test
+}
diff --git a/dev-perl/Gtk2-Notify/Manifest b/dev-perl/Gtk2-Notify/Manifest
new file mode 100644
index 000000000000..82ff8992a123
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Manifest
@@ -0,0 +1,4 @@
+AUX Gtk2-Notify-0.05-libnotify.patch 2813 BLAKE2B 07889ae9de77d0febce4419d961e98c93e1a9e55543328d95f03cd76e4363376f624aded5033c50cc767273c85a076bfeaf05f4f9fa92587df5d5a6e3a62430a SHA512 7737e1233a49117ea325001a2e6537151d29736307955f26e040ea56472d5505833022f7060d1d4a2a483bd468dd71d6f3f4222663ab4366416cd2bbafea9137
+DIST Gtk2-Notify-0.05.tar.gz 60883 BLAKE2B 0910ade464356bb8070c5c68f1135396c5a55170673ed5a81634f2441ff55dea71507de3f5edfc2b6f12711140cc3d7764d8803b3d0c3a3a3a4440ae571f57ef SHA512 e6242c21f6a3345d990830798744c8dd3abf648c0110d395197fc74b185b68189f9fc90e0fc14717cc09505d67fbaf8f45c1b3fae65c873275537e55c9e35434
+EBUILD Gtk2-Notify-0.50.0.ebuild 884 BLAKE2B 43d1695db8f2679e5fcc165029e5b2294cabc76a42978efc61f6249077a102f7be6e43ad8235cebd16dead4546477394ada344b6cd31bcb857d3ad0ba3c108ef SHA512 0d87d3835d82474429a3679c4a13f391dfef5cdc160f79b08c37846d65b1ab0dcc62492adf0b9e256592605e8b0daf7876dbe45c4b449f1b9f6236b8134a137d
+MISC metadata.xml 394 BLAKE2B b417425f47fa2dad8344a0b575df17ce7c80c1b01e79465bc0c408000add82d2f418eba53c9b5d7a682f354cb0c7c53a236d440d67bac344848998e152512fdf SHA512 0cca36ba69557ff5646ac3bed6e1e1dec80002396d0c36913769b8e0943cb28d7bca81a65b74b8114e065f90a90b55332b3248d35167c2c754c6714a37da8ca2
diff --git a/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch b/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch
new file mode 100644
index 000000000000..8865c1f3f1f0
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch
@@ -0,0 +1,114 @@
+http://bugs.gentoo.org/398699
+http://rt.cpan.org/Public/Bug/Display.html?id=67297
+http://pkgs.fedoraproject.org/gitweb/?p=perl-Gtk2-Notify.git;a=blob_plain;f=libnotify.patch;hb=HEAD
+
+--- a/t/notification.t
++++ b/t/notification.t
+@@ -2,20 +2,18 @@
+
+ use strict;
+ use warnings;
+-use Gtk2::TestHelper tests => 35;
++use Gtk2::TestHelper tests => 32;
+ use Test::Exception;
+ use Gtk2::Notify -init, $0;
+
+ ginterfaces_ok('Gtk2::Notify');
+
+-my $w = Gtk2::Window->new;
+-my $n = Gtk2::Notify->new('foo', 'bar', '', $w);
++my $n = Gtk2::Notify->new('foo', 'bar', '');
+
+ isa_ok($n, 'Gtk2::Notify');
+
+ my @methods = qw(
+ add_action
+- attach_to_widget
+ clear_actions
+ clear_hints
+ close
+@@ -46,16 +44,6 @@ lives_ok(sub {
+ }, 42);
+ }, 'add_action');
+
+-{
+- my $nw = Gtk2::Window->new;
+- lives_ok(sub {
+- $n->attach_to_widget($nw);
+- }, 'attach_to_widget');
+- lives_ok(sub {
+- $n->attach_to_widget($w);
+- }, 'attach_to_widget');
+-}
+-
+ lives_ok(sub {
+ $n->clear_actions;
+ }, 'clear_actions with existing actions');
+@@ -99,8 +87,6 @@ lives_ok(sub {
+ $n->close;
+ }, 'close before show');
+
+-$w->show_all;
+-
+ lives_ok(sub {
+ $n->show;
+ }, 'show');
+--- a/xs/Notify.xs
++++ b/xs/Notify.xs
+@@ -86,26 +86,12 @@ notify_get_server_info (class, OUTLIST c
+ MODULE = Gtk2::Notify PACKAGE = Gtk2::Notify PREFIX = notify_notification_
+
+ NotifyNotification *
+-notify_notification_new (class, summary, body=NULL, icon=NULL, attach=NULL)
++notify_notification_new (class, summary, body=NULL, icon=NULL)
+ const gchar *summary
+ const gchar *body
+ const gchar *icon
+- GtkWidget_ornull *attach
+ C_ARGS:
+- summary, body, icon, attach
+-
+-#if GTK_CHECK_VERSION (2, 9, 2)
+-
+-NotifyNotification *
+-notify_notification_new_with_status_icon (class, summary, body=NULL, icon=NULL, status_icon=NULL)
+- const gchar *summary
+- const gchar *body
+- const gchar *icon
+- GtkStatusIcon *status_icon
+- C_ARGS:
+- summary, body, icon, status_icon
+-
+-#endif
++ summary, body, icon
+
+ gboolean
+ notify_notification_update (notification, summary, message=NULL, icon=NULL)
+@@ -114,27 +100,6 @@ notify_notification_update (notification
+ const gchar *message
+ const gchar *icon
+
+-void
+-notify_notification_attach_to_widget (notification, attach)
+- NotifyNotification *notification
+- GtkWidget *attach
+-
+-#if GTK_CHECK_VERSION (2, 9, 2)
+-
+-void
+-notify_notification_attach_to_status_icon (notification, status_icon)
+- NotifyNotification *notification
+- GtkStatusIcon *status_icon
+-
+-#endif
+-
+-void
+-notify_notification_set_geometry_hints (notification, screen, x, y)
+- NotifyNotification *notification
+- GdkScreen *screen
+- gint x
+- gint y
+-
+ NO_OUTPUT gboolean
+ notify_notification_show (notification)
+ NotifyNotification *notification
diff --git a/dev-perl/Gtk2-Notify/metadata.xml b/dev-perl/Gtk2-Notify/metadata.xml
new file mode 100644
index 000000000000..d196a7fabbf3
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Gtk2-Notify</remote-id>
+ <remote-id type="cpan-module">Gtk2::Notify</remote-id>
+ </upstream>
+</pkgmetadata>