summaryrefslogtreecommitdiff
path: root/dev-perl/Gtk2-Notify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Gtk2-Notify
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Gtk2-Notify')
-rw-r--r--dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild42
-rw-r--r--dev-perl/Gtk2-Notify/Manifest6
-rw-r--r--dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch114
-rw-r--r--dev-perl/Gtk2-Notify/metadata.xml12
4 files changed, 174 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
new file mode 100644
index 000000000000..29f1002f5e8f
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=FLORA
+DIST_VERSION=0.05
+inherit perl-module virtualx
+
+DESCRIPTION="A perl interface to the notification library"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/glib-perl
+ dev-perl/Gtk2
+ >=x11-libs/libnotify-0.7
+"
+DEPEND="${RDEPEND}
+ dev-perl/ExtUtils-Depends
+ dev-perl/ExtUtils-PkgConfig
+ test? ( dev-perl/Test-Exception )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.05-libnotify.patch )
+
+PERL_RM_FILES=( t/notification.t )
+# the test dies if no notification daemon is present...
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
+
+src_test() {
+ # bug 416729
+ virtx perl-module_src_test
+}
diff --git a/dev-perl/Gtk2-Notify/Manifest b/dev-perl/Gtk2-Notify/Manifest
new file mode 100644
index 000000000000..022ebe7ada82
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Manifest
@@ -0,0 +1,6 @@
+AUX Gtk2-Notify-0.05-libnotify.patch 2813 SHA256 b86611851efd4fc0a4ed79147dc3f37975ed25c83062bedbf58b4320f50db226 SHA512 7737e1233a49117ea325001a2e6537151d29736307955f26e040ea56472d5505833022f7060d1d4a2a483bd468dd71d6f3f4222663ab4366416cd2bbafea9137 WHIRLPOOL 17c40401ef3e849b41865b317b012d320860bae059c0eeeb299f4812a3f83708d9f94e10cd2689625bf5c51140e69962edd6c67399d386a4838b27b2dba61d0d
+DIST Gtk2-Notify-0.05.tar.gz 60883 SHA256 88189ae68dfbd54615ad133df07e2ec8048d06d8b9586add1227d74eb2ebb047 SHA512 e6242c21f6a3345d990830798744c8dd3abf648c0110d395197fc74b185b68189f9fc90e0fc14717cc09505d67fbaf8f45c1b3fae65c873275537e55c9e35434 WHIRLPOOL 1b2af30bff792fc19257e34129bf19cdc3705693cc6f8992b5d712c2a2c39f46e7bc8e5d61cd4c5271cda97051f83976bebf4f7bf24b470c0e1b7c7aa29f788a
+EBUILD Gtk2-Notify-0.50.0.ebuild 884 SHA256 d8fbf068ed9f3a5abb488a932da71834c229726789350149d798bcde406fdee9 SHA512 0d87d3835d82474429a3679c4a13f391dfef5cdc160f79b08c37846d65b1ab0dcc62492adf0b9e256592605e8b0daf7876dbe45c4b449f1b9f6236b8134a137d WHIRLPOOL f630eef0eeaaf0304ae49076c820bebfb6ecb11911336ea0bf19b5aedb01e622e9bd89477d7ecf17bf02df23ab26bcb2709835e58bc8097532c792f9addf75fe
+MISC ChangeLog 2638 SHA256 014858b9caf9c6e31c9d0422fc0162889ef7f7117bdb077c8ef4203b75a28d5e SHA512 d44d10a5719e468ddb8c99b62a7f893407ec044384cd9750af5f44bb7d5092ca18df8be3d9e1073a6403853ea2424956372475f883803f48f6227910e8eebffd WHIRLPOOL 7d8de9d48ee87befdde0f432733f54bbc0d5296bfd30be84d36e01099f7ed8b8f49215cf64e8d98c58965d1d2c34f5e176fe0010379848b0f8ff350abfa11cf6
+MISC ChangeLog-2015 1622 SHA256 e712554faf26605dfbfdb16efc4a749527ff8f85da86b4cb989b3da486faf2b4 SHA512 9e13da38a683b4afb690787da8da0d95ab88d5a74ac968fd5f84dab77c1fa337a3adda0b95e1b70a085a90352de8f131e8f42a207995053fab5e48e729f1b96f WHIRLPOOL fafb0fb39af7c309e40ccaf1d0fc87e7b514d99b4b6858b1a7fc12b99bb434f710fbccebd910c99362410737699cfdd845101c1565e3ec7767c66f506957025d
+MISC metadata.xml 394 SHA256 1d3eb3758df3dd9d6edf509bae016e1874b1fc535146a0052658ead899cb52c7 SHA512 0cca36ba69557ff5646ac3bed6e1e1dec80002396d0c36913769b8e0943cb28d7bca81a65b74b8114e065f90a90b55332b3248d35167c2c754c6714a37da8ca2 WHIRLPOOL b5fda943e3125091e3381c6066e0f64f3020438cd0720ac832e128ca2d993cd8f3f341276043268b4d4689bd31315342c6e2be5f281d76891b9112e994b0706a
diff --git a/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch b/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch
new file mode 100644
index 000000000000..8865c1f3f1f0
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch
@@ -0,0 +1,114 @@
+http://bugs.gentoo.org/398699
+http://rt.cpan.org/Public/Bug/Display.html?id=67297
+http://pkgs.fedoraproject.org/gitweb/?p=perl-Gtk2-Notify.git;a=blob_plain;f=libnotify.patch;hb=HEAD
+
+--- a/t/notification.t
++++ b/t/notification.t
+@@ -2,20 +2,18 @@
+
+ use strict;
+ use warnings;
+-use Gtk2::TestHelper tests => 35;
++use Gtk2::TestHelper tests => 32;
+ use Test::Exception;
+ use Gtk2::Notify -init, $0;
+
+ ginterfaces_ok('Gtk2::Notify');
+
+-my $w = Gtk2::Window->new;
+-my $n = Gtk2::Notify->new('foo', 'bar', '', $w);
++my $n = Gtk2::Notify->new('foo', 'bar', '');
+
+ isa_ok($n, 'Gtk2::Notify');
+
+ my @methods = qw(
+ add_action
+- attach_to_widget
+ clear_actions
+ clear_hints
+ close
+@@ -46,16 +44,6 @@ lives_ok(sub {
+ }, 42);
+ }, 'add_action');
+
+-{
+- my $nw = Gtk2::Window->new;
+- lives_ok(sub {
+- $n->attach_to_widget($nw);
+- }, 'attach_to_widget');
+- lives_ok(sub {
+- $n->attach_to_widget($w);
+- }, 'attach_to_widget');
+-}
+-
+ lives_ok(sub {
+ $n->clear_actions;
+ }, 'clear_actions with existing actions');
+@@ -99,8 +87,6 @@ lives_ok(sub {
+ $n->close;
+ }, 'close before show');
+
+-$w->show_all;
+-
+ lives_ok(sub {
+ $n->show;
+ }, 'show');
+--- a/xs/Notify.xs
++++ b/xs/Notify.xs
+@@ -86,26 +86,12 @@ notify_get_server_info (class, OUTLIST c
+ MODULE = Gtk2::Notify PACKAGE = Gtk2::Notify PREFIX = notify_notification_
+
+ NotifyNotification *
+-notify_notification_new (class, summary, body=NULL, icon=NULL, attach=NULL)
++notify_notification_new (class, summary, body=NULL, icon=NULL)
+ const gchar *summary
+ const gchar *body
+ const gchar *icon
+- GtkWidget_ornull *attach
+ C_ARGS:
+- summary, body, icon, attach
+-
+-#if GTK_CHECK_VERSION (2, 9, 2)
+-
+-NotifyNotification *
+-notify_notification_new_with_status_icon (class, summary, body=NULL, icon=NULL, status_icon=NULL)
+- const gchar *summary
+- const gchar *body
+- const gchar *icon
+- GtkStatusIcon *status_icon
+- C_ARGS:
+- summary, body, icon, status_icon
+-
+-#endif
++ summary, body, icon
+
+ gboolean
+ notify_notification_update (notification, summary, message=NULL, icon=NULL)
+@@ -114,27 +100,6 @@ notify_notification_update (notification
+ const gchar *message
+ const gchar *icon
+
+-void
+-notify_notification_attach_to_widget (notification, attach)
+- NotifyNotification *notification
+- GtkWidget *attach
+-
+-#if GTK_CHECK_VERSION (2, 9, 2)
+-
+-void
+-notify_notification_attach_to_status_icon (notification, status_icon)
+- NotifyNotification *notification
+- GtkStatusIcon *status_icon
+-
+-#endif
+-
+-void
+-notify_notification_set_geometry_hints (notification, screen, x, y)
+- NotifyNotification *notification
+- GdkScreen *screen
+- gint x
+- gint y
+-
+ NO_OUTPUT gboolean
+ notify_notification_show (notification)
+ NotifyNotification *notification
diff --git a/dev-perl/Gtk2-Notify/metadata.xml b/dev-perl/Gtk2-Notify/metadata.xml
new file mode 100644
index 000000000000..d196a7fabbf3
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Gtk2-Notify</remote-id>
+ <remote-id type="cpan-module">Gtk2::Notify</remote-id>
+ </upstream>
+</pkgmetadata>