summaryrefslogtreecommitdiff
path: root/dev-perl/GraphViz/GraphViz-2.260.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-21 07:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-21 07:18:34 +0100
commite4cd098fab4f141df4d2fd24dfdc9b5f223c694b (patch)
treec8abdb0925677514b0f735dbb8f19255088ae694 /dev-perl/GraphViz/GraphViz-2.260.0.ebuild
parent7d4e34d0bcf06b357fd09a059a02687acf335132 (diff)
gentoo auto-resync : 21:06:2023 - 07:18:34
Diffstat (limited to 'dev-perl/GraphViz/GraphViz-2.260.0.ebuild')
-rw-r--r--dev-perl/GraphViz/GraphViz-2.260.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/GraphViz/GraphViz-2.260.0.ebuild b/dev-perl/GraphViz/GraphViz-2.260.0.ebuild
new file mode 100644
index 000000000000..90c3836f80d2
--- /dev/null
+++ b/dev-perl/GraphViz/GraphViz-2.260.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETJ
+DIST_VERSION=2.26
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Interface to AT&T's GraphViz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND="
+ media-gfx/graphviz
+ >=virtual/perl-Carp-1.10.0
+ >=virtual/perl-Getopt-Long-2.340.0
+ virtual/perl-IO
+ >=dev-perl/IPC-Run-0.600.0
+ >=dev-perl/libwww-perl-6
+ >=dev-perl/Parse-RecDescent-1.965.1
+ >=virtual/perl-Time-HiRes-1.510.0
+ >=dev-perl/XML-Twig-3.520.0
+ >=dev-perl/XML-XPath-1.130.0
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/File-Which
+ test? (
+ >=virtual/perl-Test-Simple-1.1.2
+ )
+"