summaryrefslogtreecommitdiff
path: root/dev-perl/Google-Ads-AdWords-Client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Google-Ads-AdWords-Client
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Google-Ads-AdWords-Client')
-rw-r--r--dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-4.18.0.ebuild54
-rw-r--r--dev-perl/Google-Ads-AdWords-Client/Manifest5
-rw-r--r--dev-perl/Google-Ads-AdWords-Client/files/4.14.0-no-dot-in-inc.patch83
-rw-r--r--dev-perl/Google-Ads-AdWords-Client/files/4.14.0-unescaped-lbracket.patch46
-rw-r--r--dev-perl/Google-Ads-AdWords-Client/metadata.xml58
5 files changed, 246 insertions, 0 deletions
diff --git a/dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-4.18.0.ebuild b/dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-4.18.0.ebuild
new file mode 100644
index 000000000000..6e8ded53ff39
--- /dev/null
+++ b/dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-4.18.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=SUNDQUIST
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Google AdWords API Perl Client Library"
+HOMEPAGE="https://github.com/googleads/googleads-perl-lib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+PATCHES=(
+ "${FILESDIR}/4.14.0-no-dot-in-inc.patch"
+ "${FILESDIR}/4.14.0-unescaped-lbracket.patch"
+)
+RDEPEND="
+ dev-perl/Class-Load
+ >=dev-perl/Class-Std-Fast-0.0.5
+ dev-perl/Crypt-OpenSSL-RSA
+ dev-perl/File-HomeDir
+ virtual/perl-File-Spec
+ dev-perl/IO-Socket-SSL
+ dev-perl/JSON-Parse
+ dev-perl/LWP-Protocol-https
+ dev-perl/libwww-perl
+ dev-perl/Log-Log4perl
+ >=dev-perl/SOAP-WSDL-2.00.10
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Template-Toolkit
+ dev-perl/URI
+ dev-perl/XML-Simple
+ dev-perl/XML-XPath
+ examples? (
+ virtual/perl-Digest-SHA
+ virtual/perl-File-Temp
+ dev-perl/HTTP-Server-Simple
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+ test? (
+ dev-perl/Config-Properties
+ dev-perl/Data-Uniqid
+ virtual/perl-File-Temp
+ dev-perl/Test-Deep
+ dev-perl/Test-Exception
+ dev-perl/Test-MockObject
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Google-Ads-AdWords-Client/Manifest b/dev-perl/Google-Ads-AdWords-Client/Manifest
new file mode 100644
index 000000000000..4e7c5ef7700c
--- /dev/null
+++ b/dev-perl/Google-Ads-AdWords-Client/Manifest
@@ -0,0 +1,5 @@
+AUX 4.14.0-no-dot-in-inc.patch 2576 BLAKE2B 599a34aabdea3b3995704712e26ffa0a88c545185fe205f37b3c618fd7063e0ede55895a9797aa1de1490cd0ba634653aca235892f17410b257b199ed16ce612 SHA512 1fb62aee9081303c1d1186a1fd388e698f519ea5856fdf86e65af2044945b85952c2dcd96b0a0a5ec4234fe82361b2e076143918193218f54934c93120b54ccf
+AUX 4.14.0-unescaped-lbracket.patch 1656 BLAKE2B 96bc78ecbc3a2ed7408a509184f88a9ee2c9ac2b2d0b4ad8c8567dcf57646d823bc92938097a7984678c18569b9d8ceb1c9f27ae76afef6ca906c4f5997f85b6 SHA512 8ba173dff927bf5dd7193d88fe110bdaf71b44b54e3e5a3a0d8ff161ce492a36324c5e69dfca268577ecbbf81d3b99247f7fe305bd4bd2f172e59ea52b9146c1
+DIST Google-Ads-AdWords-Client-4.18.0.tar.gz 8921326 BLAKE2B 6e012147b212f734b7c6910b2f59085652acf45a4971157cd6854d37316bc238edb8b1bb1358c1dac200ce43a326f104d02de9ffea9f0ac19839180936943602 SHA512 b0905c69f52909f160e563fd4e24413256d14797d7d9bf40bb1193d7bb42deb65c4030a6d117a9c6a3b1fa6bcbb20ac6a5922dcfc4ba7c67566157e4097d5391
+EBUILD Google-Ads-AdWords-Client-4.18.0.ebuild 1206 BLAKE2B 7e63526c15eaa49da2c74920322ed42534e4819634b6d834fcba6f06061b9e85f9179c034022876e43a2d6772e71c4086cad37cf438c9578842077d7b4ff44d8 SHA512 eadf3dedb6eb54fdb888f559b8e35f7d6ce393a9a25a53d0519005d2129fdd29b2012529d97fe5caee12ed20ac96af014d4237e8acceaebcf39a4212f6cb0c93
+MISC metadata.xml 4424 BLAKE2B 517363b807ff8182aa3c6568f66054962e69528681a9549d4bbf6c6648414dc65e0a20f1201c2c2640820c9333f0a74eb84eb30c5c57ec57c6b041ea3b6414ce SHA512 a561f60bdeec595bd9bd11b80aca2c457aa652f01260fd49602c2568f8cbab269d7d49a71466726dedc2cbc5e789aa693c1856995c73a7239f6bf5d5cbbeff50
diff --git a/dev-perl/Google-Ads-AdWords-Client/files/4.14.0-no-dot-in-inc.patch b/dev-perl/Google-Ads-AdWords-Client/files/4.14.0-no-dot-in-inc.patch
new file mode 100644
index 000000000000..218cb69b1483
--- /dev/null
+++ b/dev-perl/Google-Ads-AdWords-Client/files/4.14.0-no-dot-in-inc.patch
@@ -0,0 +1,83 @@
+From a67324b5622088422b0b0c1a403c594312452d16 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 4 Jun 2017 07:35:25 +1200
+Subject: [PATCH 1/3] t/001_require.t: Force a relative path load for require
+ test
+
+require_ok("Foo") is implemented in terms of require "Foo"
+
+This means:
+
+require "Foo.pm"
+
+Only loads "Foo.pm" from "." if:
+
+- '.' is in @INC ( Not true by default in Perl >5.25.11 )
+- Foo.pm is not installed in Perl5lib ( dangerous assumption )
+
+This forces require to side-step @INC traversal by using an explicit
+prefix of "./", which is special-cased in require.
+
+This fixes RT#120674
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120674
+---
+ t/001_require.t | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/t/001_require.t b/t/001_require.t
+index fe0d205..d70b2d2 100755
+--- a/t/001_require.t
++++ b/t/001_require.t
+@@ -24,7 +24,7 @@ use File::Spec;
+ use Test::More qw(no_plan);
+
+ # Set up @INC at runtime with an absolute path.
+-my $lib_path = File::Spec->catdir(dirname($0), "..", "lib");
++my $lib_path = File::Spec->rel2abs(File::Spec->catdir(dirname($0), "..", "lib"));
+ push(@INC, $lib_path);
+
+ require_ok 'Google::Ads::AdWords::Client';
+@@ -38,6 +38,6 @@ sub test_require {
+ local $SIG{__WARN__} = sub {
+ warn @_ unless $_[0] =~ /redefine/;
+ };
+- require_ok($file_name);
++ require_ok("./$file_name");
+ }
+ }
+--
+2.12.2
+
+From 76f5a421585b8c85b7e39b91adb0b257d1d83665 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 4 Jun 2017 07:40:01 +1200
+Subject: [PATCH 2/3] t/020_GenerateOfflineCredentials.t: Force relative path
+ for script
+
+require "some/path.pl" previously fell into worknig due to '.' being
+in @INC, as this still invokes @INC traversal
+
+This change simply forces a "./" so that Perl uses direct access via
+a special-cased path instead of relying on @INC traversal, which becomes
+unsafe to depend on since Perl 5.25.11
+---
+ t/020_GenerateOfflineCredentials.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/020_GenerateOfflineCredentials.t b/t/020_GenerateOfflineCredentials.t
+index 0dcde9d..dfa8b50 100755
+--- a/t/020_GenerateOfflineCredentials.t
++++ b/t/020_GenerateOfflineCredentials.t
+@@ -51,7 +51,7 @@ my $stdout;
+ open(STDOUT, ">", \$stdout);
+
+ # Calling the offline credentials code
+-require qw(examples/oauth/generate_offline_credentials.pl);
++require qw(./examples/oauth/generate_offline_credentials.pl);
+ ok(generate_offline_credentials($client));
+
+ # Checking the auth mock was correctly called
+--
+2.12.2
+
diff --git a/dev-perl/Google-Ads-AdWords-Client/files/4.14.0-unescaped-lbracket.patch b/dev-perl/Google-Ads-AdWords-Client/files/4.14.0-unescaped-lbracket.patch
new file mode 100644
index 000000000000..4e7a4546f9cd
--- /dev/null
+++ b/dev-perl/Google-Ads-AdWords-Client/files/4.14.0-unescaped-lbracket.patch
@@ -0,0 +1,46 @@
+From a7e92591ac0415fbb7119e4ad7572f910e4fdb8f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 4 Jun 2017 07:43:59 +1200
+Subject: [PATCH 3/3] Fix unescaped "{" error in tests t/022* and t/024*
+
+Perl 5.26 makes use of literal unescaped { in a regex illegal,
+and this leads to test failures.
+
+This change simply quotes the offending characters to make tests pass.
+
+This closes RT#118509
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=118509
+---
+ t/022_ReportUtils.t | 2 +-
+ t/024_BatchJobHandler.t | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/t/022_ReportUtils.t b/t/022_ReportUtils.t
+index 4f5f326..d0e2000 100755
+--- a/t/022_ReportUtils.t
++++ b/t/022_ReportUtils.t
+@@ -57,7 +57,7 @@ my $report_as_string = $report_handler->get_as_string();
+ ok(!$report_as_string, "report as string");
+ ok($report_as_string->isa("Google::Ads::Common::ReportDownloadError"),
+ "check report handler->report_as_string return type");
+-ok($report_as_string =~ /ReportDownloadError\s{[^}]+}/,
++ok($report_as_string =~ /ReportDownloadError\s\{[^}]+}/,
+ "check ReportDownloadError STRINGIFY");
+
+ my ($fh, $filename) = tempfile();
+diff --git a/t/024_BatchJobHandler.t b/t/024_BatchJobHandler.t
+index 15983ae..4b86703 100755
+--- a/t/024_BatchJobHandler.t
++++ b/t/024_BatchJobHandler.t
+@@ -133,6 +133,6 @@ my $batch_job_handler_error =
+ description => "test"
+ });
+ ok(!$batch_job_handler_error, "BOOLIFY on error false");
+-ok($batch_job_handler_error =~ /BatchJobHandlerError\s{[^}]+}/,
++ok($batch_job_handler_error =~ /BatchJobHandlerError\s\{[^}]+}/,
+ "check BatchJobHandlerError STRINGIFY");
+
+--
+2.12.2
+
diff --git a/dev-perl/Google-Ads-AdWords-Client/metadata.xml b/dev-perl/Google-Ads-AdWords-Client/metadata.xml
new file mode 100644
index 000000000000..d1774500bbac
--- /dev/null
+++ b/dev-perl/Google-Ads-AdWords-Client/metadata.xml
@@ -0,0 +1,58 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">googleads/googleads-perl-lib</remote-id>
+ <remote-id type="cpan">Google-Ads-AdWords-Client</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Client</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Constants</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Deserializer</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::FaultDetail</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Logging</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::OAuth2ApplicationsHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::OAuth2ServiceAccountsHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::DateRange</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::DateRangeType</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::DownloadFormat</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::Operator</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::OrderBy</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::Paging</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::Predicate</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::ReportDefinition</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::ReportType</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::ReportingConfiguration</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::Selector</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::SortOrder</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::RequestStats</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Serializer</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Utilities::BatchJobHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Utilities::BatchJobHandlerError</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Utilities::BatchJobHandlerStatus</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Utilities::PageProcessor</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::AuthError</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::AuthHandlerInterface</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::CaptchaRequiredError</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::Constants</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::ErrorUtils</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::HTTPTransport</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::MapUtils</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::MediaUtils</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::OAuth2ApplicationsHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::OAuth2BaseHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::OAuth2ServiceAccountsHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::OAuthApplicationsHandlerInterface</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::ReportDownloadError</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::ReportDownloadHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::ReportUtils</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::Utilities::AdsUtilityRegistry</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::XPathSAXParser</remote-id>
+ <remote-id type="cpan-module">Google::Ads::SOAP::Deserializer::MessageParser</remote-id>
+ <remote-id type="cpan-module">Google::Ads::SOAP::Generator::Generator</remote-id>
+ <remote-id type="cpan-module">Google::Ads::SOAP::Generator::TypemapVisitor</remote-id>
+ <remote-id type="cpan-module">Google::Ads::SOAP::Typelib::ComplexType</remote-id>
+ </upstream>
+</pkgmetadata>