summaryrefslogtreecommitdiff
path: root/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 10:33:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 10:33:02 +0100
commit6440e1dd038e7df4f9df7dd5127d3b1c6f39034e (patch)
tree122c8899fbcce481ff7c1deb35c872f0236affa9 /dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild
parente7bc5cacb1abeb6806d255e2a817ab4dcb5f52b8 (diff)
gentoo auto-resync : 09:09:2023 - 10:33:01
Diffstat (limited to 'dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild')
-rw-r--r--dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild
new file mode 100644
index 000000000000..2683fe8a0478
--- /dev/null
+++ b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.51.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=0.051
+inherit perl-module xdg-utils
+
+DESCRIPTION="Dynamically create Perl language bindings"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-perl/glib-perl-1.320.0
+ >=dev-libs/gobject-introspection-1.0
+ >=dev-libs/libffi-3.0.0:=
+ >=dev-libs/glib-2.0.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+"
+
+pkg_setup() {
+ # bug #599128
+ xdg_environment_reset
+}