summaryrefslogtreecommitdiff
path: root/dev-perl/Getopt-Long-Descriptive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-perl/Getopt-Long-Descriptive
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-perl/Getopt-Long-Descriptive')
-rw-r--r--dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.109.0.ebuild40
-rw-r--r--dev-perl/Getopt-Long-Descriptive/Manifest2
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.109.0.ebuild b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.109.0.ebuild
new file mode 100644
index 000000000000..c975095d9c6b
--- /dev/null
+++ b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.109.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.109
+inherit perl-module
+
+DESCRIPTION="Getopt::Long with usage text"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+CONFLICTS="!<dev-perl/MooseX-Getopt-0.660.0"
+
+# File::Basename -> perl
+# List::Util, Scalar::Util -> perl-Scalar-List-Utils
+# Sub::Exporter::Util -> Sub-Exporter
+RDEPEND="${CONFLICTS}
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.330.0
+ >=dev-perl/Params-Validate-0.970.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Sub-Exporter-0.972.0
+"
+
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? ( >=virtual/perl-CPAN-Meta-2.120.900 )
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"
diff --git a/dev-perl/Getopt-Long-Descriptive/Manifest b/dev-perl/Getopt-Long-Descriptive/Manifest
index e3b150015a17..759ba40f14ea 100644
--- a/dev-perl/Getopt-Long-Descriptive/Manifest
+++ b/dev-perl/Getopt-Long-Descriptive/Manifest
@@ -1,3 +1,5 @@
DIST Getopt-Long-Descriptive-0.103.tar.gz 32683 BLAKE2B 9e457690d61e8b2330761ffd09174403d7e485c80af84d2cc61b7443762dcbe9832a15c589b729536103e80c75556f60040d5d1d3637a5eb3226bf1cc1d57ce6 SHA512 9229575bde794fa1213871fbb33a12222737d7979cf4c290200fd85c7da9e3227539809b8380a88a85675429ceb61e505bac8cc4e1408ca63ba92b4e1b33149f
+DIST Getopt-Long-Descriptive-0.109.tar.gz 33959 BLAKE2B c936f820654a5a14dfef706f26514334463b119b161643bbeb831802d9b7403c49f1cccd0414da855ef1bed424d88b78a220f037fb2d723ecce8d7ede54840e9 SHA512 9bd3af84119264c9e7e72b470f54782fe0a9e37e6071052a7b43af9529087841f77f06f81a70e4cab05380558216893b0902aabefcfbc970916f65614666969a
EBUILD Getopt-Long-Descriptive-0.103.0.ebuild 977 BLAKE2B d787db62716b270cb9d482392c0b24d46c8165dd1b3a1f6edb80635dc009143ab300c84d64e0cd1a8197d602d2d47c2ed72a5ebd2404826d4cb6be4f7c7f8689 SHA512 8d1f30fc8ab4f7ecf381f67bc3737912acbc4873472fa9a8a681b2a1ff7a971d3cc19976e7e8920cdd79f559bb5bfcf7b2c2380c2c388cba12ab1e45ea8c131f
+EBUILD Getopt-Long-Descriptive-0.109.0.ebuild 984 BLAKE2B 6085b004a80182fccbb9851ccd5d10ffe211c743ec8c4a27e07d168bf85ef1c95d6c1e0f46b110ee0942f24426ce8f3fcbc2b4c332039b60ec670c0e447a1445 SHA512 25b56721637e037e5698e3d39f4ad9c316c9d77f35961d7a17b49db0d81dd5fc85eb6b6a1436e8f84b26034ee1d6236ffd1dd3d7d7755ff032be87d146d8ce31
MISC metadata.xml 576 BLAKE2B 284499ae9040033acd83c3f9ca6f5263c1b0652146333fff6e808587149264f7114d523c116c84f1e133cb558da9095403197da0c90f917777791e869515aef1 SHA512 4a83ea267c2c7d62a81da04c2afd355b6a6d35a1fb6dd8e2fb22b23e59b269b01ce6a91e1a76ca36ae6c621bf33e0fad295c733cc7f84255416c0aa146162bcc