summaryrefslogtreecommitdiff
path: root/dev-perl/Getopt-Long-Descriptive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Getopt-Long-Descriptive
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Getopt-Long-Descriptive')
-rw-r--r--dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.100.0.ebuild37
-rw-r--r--dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.97.0.ebuild25
-rw-r--r--dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.99.0.ebuild35
-rw-r--r--dev-perl/Getopt-Long-Descriptive/Manifest7
-rw-r--r--dev-perl/Getopt-Long-Descriptive/metadata.xml14
5 files changed, 118 insertions, 0 deletions
diff --git a/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.100.0.ebuild b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.100.0.ebuild
new file mode 100644
index 000000000000..41089548ac8e
--- /dev/null
+++ b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.100.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.100
+inherit perl-module
+
+DESCRIPTION="Getopt::Long with usage text"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test minimal"
+
+CONFLICTS="!<dev-perl/MooseX-Getopt-0.660.0"
+# File::Basename -> perl
+# List::Util, Scalar::Util -> perl-Scalar-List-Utils
+# Sub::Exporter::Util -> Sub-Exporter
+RDEPEND="${CONFLICTS}
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.330.0
+ >=dev-perl/Params-Validate-0.970.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Sub-Exporter-0.972.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? ( >=virtual/perl-CPAN-Meta-2.120.900 )
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"
diff --git a/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.97.0.ebuild b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.97.0.ebuild
new file mode 100644
index 000000000000..aa803c265eb8
--- /dev/null
+++ b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.97.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=RJBS
+MODULE_VERSION=0.097
+inherit perl-module
+
+DESCRIPTION="Getopt::Long with usage text"
+
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Params-Validate-0.970.0
+ dev-perl/IO-stringy
+ dev-perl/Sub-Exporter
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Warnings )"
+
+SRC_TEST=do
diff --git a/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.99.0.ebuild b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.99.0.ebuild
new file mode 100644
index 000000000000..3088e1d4da16
--- /dev/null
+++ b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.99.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.099
+inherit perl-module
+
+DESCRIPTION="Getopt::Long with usage text"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test minimal"
+
+# File::Basename -> perl
+# List::Util, Scalar::Util -> perl-Scalar-List-Utils
+# Sub::Exporter::Util -> Sub-Exporter
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.330.0
+ >=dev-perl/Params-Validate-0.970.0
+ >=dev-perl/Sub-Exporter-0.972.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? ( >=virtual/perl-CPAN-Meta-2.120.900 )
+ dev-perl/Test-Fatal
+ >=dev-perl/Test-Warnings-0.5.0
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
diff --git a/dev-perl/Getopt-Long-Descriptive/Manifest b/dev-perl/Getopt-Long-Descriptive/Manifest
new file mode 100644
index 000000000000..2cfe1191bd0a
--- /dev/null
+++ b/dev-perl/Getopt-Long-Descriptive/Manifest
@@ -0,0 +1,7 @@
+DIST Getopt-Long-Descriptive-0.097.tar.gz 26399 BLAKE2B d14bbb75b5ae993970eb694ce54c16ac6670ece915368a58a482922d9c2b7d622cf012d20361e4f432bbf7b6119919e622f5b820f14a6e66dc62cfe7c99e9f19 SHA512 9b1a11bce5a64b0dbae93d410593c6411790db8eac1169eb1703fdd4b0bffc0cb0ce12fd02c3de0b4fea98151bcc98af55cf46d84d658c8292291bf3baf5d28d
+DIST Getopt-Long-Descriptive-0.099.tar.gz 29651 BLAKE2B 1adf8c6c84fc8b6251d27b8082b21c886b261bd633a1a6936721a34fafe2da5510e1ead960a079db3ac9dfa7fcf8b490e53fa8fb332952cd9ec5141ef357225d SHA512 3b6fdf06eab25f53c5624e42a8024d059d1ee1c33361184a1d45fc5f0f9b521ad0749916ca7ec7d9561bc2c297adba520ff1fd5efa6706ca480697fad71290da
+DIST Getopt-Long-Descriptive-0.100.tar.gz 31366 BLAKE2B 09fac34156dfbd22f3d14f85b44c0c327e0d6e7b535d2c4b80a492a1f4ab184b85d7b14456c375ce6cf882c69c4e99e3341a6ee764fea6ea966b85068a2410cb SHA512 0efd6f707487b9b44d5c3b5c9e46c3718546e44bf1b66c198be6ebfc922e7bdb23a9c57c5a9c0985dc3769617141696750e1bd982457247b679e3bdb5f9f16c7
+EBUILD Getopt-Long-Descriptive-0.100.0.ebuild 921 BLAKE2B 10fffd1d65837aaba26d369d05a87b198bcb1ebefe557504fd83f11a50ba5ed75a099d23401b3ecd7a69789db4388081a477ec75a891e6957384a8f0830d4808 SHA512 df3b1827143c1b3b94345eaf9d81fe9381bb2d3240d5902a8948d74bccd77678d32e79e23204f1d6ba91d60f5d8fbc6a083d714b62cd44a5edf315e6e7abb58a
+EBUILD Getopt-Long-Descriptive-0.97.0.ebuild 496 BLAKE2B 3366402b641d0271739f5db595546a44a7cb6ab39052b58ff17b2cf0c9368ca3a7b70bc5f411a478f6cdb056e3d3215f66dfe663aa0866347b089e09ecea7cca SHA512 9979eb9461a10fb72668276126db56bd5cb3daabe766b7cc6cade4cf532a180425bd95c6b0e1fa4019ee1670c052b3e5e1803fc6764aeb479915b44d9ce4d0a1
+EBUILD Getopt-Long-Descriptive-0.99.0.ebuild 831 BLAKE2B 0c330b00f58285f298cb4e993bcb62608452cb915c6f1f11cf2f8a1a7a88ee121ff5ff3fdf76d6336fc91d8f5b887e9f0558127949279e47c9a4995433c120e9 SHA512 121c9f03e4f8da125c3f42b3b01320c6ac4a3ed108ccda8dd674051977130b6263a05a78d87990287f4a71d7f77e613fab8f2513cece285eeff40ee6916f4e7c
+MISC metadata.xml 576 BLAKE2B 284499ae9040033acd83c3f9ca6f5263c1b0652146333fff6e808587149264f7114d523c116c84f1e133cb558da9095403197da0c90f917777791e869515aef1 SHA512 4a83ea267c2c7d62a81da04c2afd355b6a6d35a1fb6dd8e2fb22b23e59b269b01ce6a91e1a76ca36ae6c621bf33e0fad295c733cc7f84255416c0aa146162bcc
diff --git a/dev-perl/Getopt-Long-Descriptive/metadata.xml b/dev-perl/Getopt-Long-Descriptive/metadata.xml
new file mode 100644
index 000000000000..581fb51f08dc
--- /dev/null
+++ b/dev-perl/Getopt-Long-Descriptive/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Getopt-Long-Descriptive</remote-id>
+ <remote-id type="cpan-module">Getopt::Long::Descriptive</remote-id>
+ <remote-id type="cpan-module">Getopt::Long::Descriptive::Opts</remote-id>
+ <remote-id type="cpan-module">Getopt::Long::Descriptive::Usage</remote-id>
+ </upstream>
+</pkgmetadata>