summaryrefslogtreecommitdiff
path: root/dev-perl/Filesys-SmbClient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-perl/Filesys-SmbClient
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-perl/Filesys-SmbClient')
-rw-r--r--dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild68
-rw-r--r--dev-perl/Filesys-SmbClient/Manifest2
-rw-r--r--dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.2-no-magic-libdir.patch52
3 files changed, 122 insertions, 0 deletions
diff --git a/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild b/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild
new file mode 100644
index 000000000000..adf20536a0e7
--- /dev/null
+++ b/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ALIAN
+DIST_VERSION=3.2
+inherit perl-module autotools
+
+DESCRIPTION="Provide Perl API for libsmbclient.so"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=net-fs/samba-4.2[client]"
+DEPEND=">=net-fs/samba-4.2[client]"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/pkgconfig
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-close_fn.patch"
+ "${FILESDIR}/${PN}-3.2-no-magic-libdir.patch"
+)
+
+src_prepare() {
+ perl-module_src_prepare
+ cp -vf configure.in configure.ac || die "Can't copy configure.in"
+ perl_rm_files configure.in
+ eautoreconf
+}
+src_configure() {
+ GENTOO_INC_SMBCLIENT="$( pkg-config --variable=includedir smbclient )" \
+ GENTOO_LIB_SMBCLIENT="$( pkg-config --variable=libdir smbclient )" \
+ perl-module_src_configure
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+src_test() {
+ local MODULES=(
+ "Filesys::SmbClient ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ # standard tests are not designed to work on a non-developer system.
+}
diff --git a/dev-perl/Filesys-SmbClient/Manifest b/dev-perl/Filesys-SmbClient/Manifest
index 20b29279febe..942a41d219db 100644
--- a/dev-perl/Filesys-SmbClient/Manifest
+++ b/dev-perl/Filesys-SmbClient/Manifest
@@ -1,5 +1,7 @@
+AUX Filesys-SmbClient-3.2-no-magic-libdir.patch 1503 BLAKE2B e74eba0b038ac4da9274163070f46e8670cb8b58aa6358e5fa09fc6a02ffea72efcd16f0a40487f9c35a7d2d70406b8acffe1cad4241c59b7e86d2f22137b843 SHA512 6c39b2acf4922db11476cf86a5bb31b8608b8b07d91caab67dd22e2fadb9b1ed829f4aecf8adec3c7ff8dceaffaf24ef9fbbefdb833223e1b7f3bf9edbde9675
AUX Filesys-SmbClient-3.200.0-close_fn.patch 589 BLAKE2B 4de9ea459b5aea38851a72d1b2cf8e716c6ac1770cf36bdb870d5120f6efab9cbedfb5e10134d4be0324f353b050525f280166799db39db74318260d46fe125f SHA512 3e175b79d7c376305e0b6df7b81995d7618de779fa71c0e38c9f845fd7b05d996366763b894219c655aa2f10f6009b792c1dd4f3ee4bfdcd028789f7e7773ce1
AUX Filesys-SmbClient-3.200.0-pkg_config.patch 970 BLAKE2B 1f7ecdc4ef3f4a3e8d2e8bb9d9ea50817cfb7327b9ab3071adea983c65af4fbc8fe6482ec855b77106800f82b7c7022d264f03fd013fcc6dbe6cf8793d6819b6 SHA512 69745324011b76771b5df278083f0780bf03807a1211d04544bf8969a6cd54d6a32064c211d28bbbfc9191337eb16e5634952f473c675bc2ccb9151656caf916
DIST Filesys-SmbClient-3.2.tar.gz 52010 BLAKE2B 1c88cedf7536f62fa2d6639425036002e02359b6c07bfd959a8085c797e7c23e3fead10450c73c85eefc42001beba6e8c2d5ca9cf050f1bac91b7b4129775b04 SHA512 547ad4c94a7cd88e5ac07938d2e315acf416810596979efb40fe036614535cdb1ad7f73bb17f3b6c18b62187a09a2613bc548a9dede6c399673962d9eb837427
EBUILD Filesys-SmbClient-3.200.0-r3.ebuild 1025 BLAKE2B 600f4dbaf750b5b7a740ad3bec28dd5b5beb1e6c461d68f6a5b9156749a708afcc30c2d26a7a81d2045e92f1e7f1ffdfeafece716998997b468771e99305bfa8 SHA512 d341b1cc0fc206dd56c6ef6c0b893d850f637681973e2a15118c8d0707fd18e9e5be2767031115068cc995aeb6121996691fa8750a5c2069807c490ec4ab30d3
+EBUILD Filesys-SmbClient-3.200.0-r4.ebuild 1506 BLAKE2B b7719550c3793795d04b0010ae3fa5c5ad63ed09de40c428c3b56316adb76edd2c0a6c099a8b4b6c6089cede469cf83c7b38b7a625861ea2597796b9ed27023b SHA512 23e7a1cb1c982791b3c67fa70b16e492e1670c3b5e3ecb7c2bc6796f305faae88031c9cd21612e066d05ce842af902147884ce100f42b785ae7a62a1a32719ca
MISC metadata.xml 406 BLAKE2B 42977daeb8c4429ec89887ed665af51aef0cf2d9f85581c1bf04484662b4c84959ee2776eb8c5309650f8c55e1cbac3b9b46e0ad0b747c4aa0dde13d47018c0a SHA512 4189f37bd1afdfc233b1a3a763f65a372286d25807753f36dbd813300ae6b8334062388edb48061fb6f81c12bd1b076b514026ab397ee3b611dbff67ac2df3df
diff --git a/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.2-no-magic-libdir.patch b/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.2-no-magic-libdir.patch
new file mode 100644
index 000000000000..337a23386071
--- /dev/null
+++ b/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.2-no-magic-libdir.patch
@@ -0,0 +1,52 @@
+From 9f3c784d483623edb65f6e9579fd1a34e885f766 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 10 Sep 2020 11:34:38 +1200
+Subject: Strip automagic detection if include/ and lib/ dirs.
+
+---
+ Makefile.PL | 16 ++++++++++------
+ 1 file changed, 10 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 954df92..ccd842a 100755
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -6,14 +6,14 @@ my ($define, $ccfl);
+ ($^O =~ m/AIX/i) ? ($ccfl = '-qcpluscmt') : ($ccfl = '');
+
+ # path libsmbclient.h
+-my $include = try_to_find("libsmbclient.h");
+-$include = prompt("Where can I find libsmbclient.h ?", $include);
+-warn_user("$include/libsmbclient.h") if (!-r "$include/libsmbclient.h");
++my $include = $ENV{GENTOO_INC_SMBCLIENT};
++die "No GENTOO_INC_SMBCLIENT" if not defined $include;
++die "No $include/libsmbclient.h" if not -r "$include/libsmbclient.h";
+
+ # path libsmbclient.so
+-my $lib = try_to_find("libsmbclient.so");
+-$lib = prompt("Where can I find libsmbclient.so ?",$lib);
+-warn_user("libsmbclient.so") if (!-r "$lib/libsmbclient.so");
++my $lib = $ENV{GENTOO_LIB_SMBCLIENT};
++die "No GENTOO_LIB_SMBCLIENT" if not defined $lib;
++die "No $lib/libsmbclient.so" if not -r "$lib/libsmbclient.so";
+
+ # tests demande ?
+ my $ans =
+@@ -87,6 +87,8 @@ EOF
+
+ }
+
++=cut
++
+ sub try_to_find {
+ my $name = shift;
+ my @path = find_path($name);
+@@ -113,3 +115,5 @@ sub find_path {
+ print "I search in: ",(join "\n", @path),"\n";
+ return @path;
+ }
++
++=cut
+--
+2.28.0
+