summaryrefslogtreecommitdiff
path: root/dev-perl/Filesys-SmbClient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Filesys-SmbClient
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Filesys-SmbClient')
-rw-r--r--dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r3.ebuild50
-rw-r--r--dev-perl/Filesys-SmbClient/Manifest5
-rw-r--r--dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-close_fn.patch18
-rw-r--r--dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-pkg_config.patch36
-rw-r--r--dev-perl/Filesys-SmbClient/metadata.xml12
5 files changed, 121 insertions, 0 deletions
diff --git a/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r3.ebuild b/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r3.ebuild
new file mode 100644
index 000000000000..88ce0aaeace1
--- /dev/null
+++ b/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ALIAN
+DIST_VERSION=3.2
+inherit perl-module autotools
+
+DESCRIPTION="Provide Perl API for libsmbclient.so"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=net-fs/samba-4.2[client]"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-pkg_config.patch"
+ "${FILESDIR}/${P}-close_fn.patch"
+)
+
+src_prepare() {
+ perl-module_src_prepare
+ eautoreconf
+}
+src_test() {
+ local MODULES=(
+ "Filesys::SmbClient ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ # standard tests are not designed to work on a non-developer system.
+}
diff --git a/dev-perl/Filesys-SmbClient/Manifest b/dev-perl/Filesys-SmbClient/Manifest
new file mode 100644
index 000000000000..20b29279febe
--- /dev/null
+++ b/dev-perl/Filesys-SmbClient/Manifest
@@ -0,0 +1,5 @@
+AUX Filesys-SmbClient-3.200.0-close_fn.patch 589 BLAKE2B 4de9ea459b5aea38851a72d1b2cf8e716c6ac1770cf36bdb870d5120f6efab9cbedfb5e10134d4be0324f353b050525f280166799db39db74318260d46fe125f SHA512 3e175b79d7c376305e0b6df7b81995d7618de779fa71c0e38c9f845fd7b05d996366763b894219c655aa2f10f6009b792c1dd4f3ee4bfdcd028789f7e7773ce1
+AUX Filesys-SmbClient-3.200.0-pkg_config.patch 970 BLAKE2B 1f7ecdc4ef3f4a3e8d2e8bb9d9ea50817cfb7327b9ab3071adea983c65af4fbc8fe6482ec855b77106800f82b7c7022d264f03fd013fcc6dbe6cf8793d6819b6 SHA512 69745324011b76771b5df278083f0780bf03807a1211d04544bf8969a6cd54d6a32064c211d28bbbfc9191337eb16e5634952f473c675bc2ccb9151656caf916
+DIST Filesys-SmbClient-3.2.tar.gz 52010 BLAKE2B 1c88cedf7536f62fa2d6639425036002e02359b6c07bfd959a8085c797e7c23e3fead10450c73c85eefc42001beba6e8c2d5ca9cf050f1bac91b7b4129775b04 SHA512 547ad4c94a7cd88e5ac07938d2e315acf416810596979efb40fe036614535cdb1ad7f73bb17f3b6c18b62187a09a2613bc548a9dede6c399673962d9eb837427
+EBUILD Filesys-SmbClient-3.200.0-r3.ebuild 1025 BLAKE2B 600f4dbaf750b5b7a740ad3bec28dd5b5beb1e6c461d68f6a5b9156749a708afcc30c2d26a7a81d2045e92f1e7f1ffdfeafece716998997b468771e99305bfa8 SHA512 d341b1cc0fc206dd56c6ef6c0b893d850f637681973e2a15118c8d0707fd18e9e5be2767031115068cc995aeb6121996691fa8750a5c2069807c490ec4ab30d3
+MISC metadata.xml 406 BLAKE2B 42977daeb8c4429ec89887ed665af51aef0cf2d9f85581c1bf04484662b4c84959ee2776eb8c5309650f8c55e1cbac3b9b46e0ad0b747c4aa0dde13d47018c0a SHA512 4189f37bd1afdfc233b1a3a763f65a372286d25807753f36dbd813300ae6b8334062388edb48061fb6f81c12bd1b076b514026ab397ee3b611dbff67ac2df3df
diff --git a/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-close_fn.patch b/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-close_fn.patch
new file mode 100644
index 000000000000..a923ae11a9b4
--- /dev/null
+++ b/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-close_fn.patch
@@ -0,0 +1,18 @@
+diff --git a/configure.in b/configure.in
+index 9660e93..f1d2350 100644
+--- a/configure.in
++++ b/configure.in
+@@ -48,8 +48,8 @@ fi
+
+ dnl This is context->close_fn or context close ?
+ AC_TRY_COMPILE([#include <libsmbclient.h>],
+- [SMBCCTX *c; c->close_fn(c,0);],
+- smbctxclosefn=yes, smbctxclosefn=no)
++ [SMBCCTX *c; c->close(c,0);],
++ smbctxclosefn=no, smbctxclosefn=yes)
+ if test "$smbctxclosefn" = yes; then
+ AC_DEFINE(HAVE_CLOSEFN,, [define if SMBCTXX->close_fn exist.])
+ AC_MSG_RESULT([You use SMBCTXX->close_fn (release >= 3.0.20). ])
+--
+2.7.3
+
diff --git a/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-pkg_config.patch b/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-pkg_config.patch
new file mode 100644
index 000000000000..2a2b08089726
--- /dev/null
+++ b/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-pkg_config.patch
@@ -0,0 +1,36 @@
+From fa320a06147079458aa5f4834ae8b22cfe278481 Mon Sep 17 00:00:00 2001
+From: Dennis Lichtenthaeler <dennis.lichtenthaeler@stiftung-tannenhof.de>
+Date: Wed, 27 Apr 2016 10:57:17 +0200
+Subject: [PATCH 3/3] Use pkg-config instead of trickery to find samba-4
+ libs/headers
+
+---
+ Makefile.PL | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 954df92..ed9d846 100755
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -110,6 +110,18 @@ sub find_path {
+ push(@path, $_."/$ext") if !$defaultsDir->{$_};
+ }
+ foreach (keys %$defaultsDir) { push(@path, $_."/$ext"); }
++
++ ## get default paths from pkg-config
++ my $pkgconfig;
++ if($_[0]=~m!\.h$!) {
++ $pkgconfig = qx/pkg-config --variable=includedir smbclient/;
++ }
++ else {
++ $pkgconfig = qx/pkg-config --variable=libdir smbclient/;
++ }
++ $pkgconfig =~ s/\n//g;
++ push(@path, $pkgconfig);
++
+ print "I search in: ",(join "\n", @path),"\n";
+ return @path;
+ }
+--
+2.7.3
+
diff --git a/dev-perl/Filesys-SmbClient/metadata.xml b/dev-perl/Filesys-SmbClient/metadata.xml
new file mode 100644
index 000000000000..6894c343f13b
--- /dev/null
+++ b/dev-perl/Filesys-SmbClient/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Filesys-SmbClient</remote-id>
+ <remote-id type="cpan-module">Filesys::SmbClient</remote-id>
+ </upstream>
+</pkgmetadata>