summaryrefslogtreecommitdiff
path: root/dev-perl/Filesys-SmbClient/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Filesys-SmbClient/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Filesys-SmbClient/files')
-rw-r--r--dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-close_fn.patch18
-rw-r--r--dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-pkg_config.patch36
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-close_fn.patch b/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-close_fn.patch
new file mode 100644
index 000000000000..a923ae11a9b4
--- /dev/null
+++ b/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-close_fn.patch
@@ -0,0 +1,18 @@
+diff --git a/configure.in b/configure.in
+index 9660e93..f1d2350 100644
+--- a/configure.in
++++ b/configure.in
+@@ -48,8 +48,8 @@ fi
+
+ dnl This is context->close_fn or context close ?
+ AC_TRY_COMPILE([#include <libsmbclient.h>],
+- [SMBCCTX *c; c->close_fn(c,0);],
+- smbctxclosefn=yes, smbctxclosefn=no)
++ [SMBCCTX *c; c->close(c,0);],
++ smbctxclosefn=no, smbctxclosefn=yes)
+ if test "$smbctxclosefn" = yes; then
+ AC_DEFINE(HAVE_CLOSEFN,, [define if SMBCTXX->close_fn exist.])
+ AC_MSG_RESULT([You use SMBCTXX->close_fn (release >= 3.0.20). ])
+--
+2.7.3
+
diff --git a/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-pkg_config.patch b/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-pkg_config.patch
new file mode 100644
index 000000000000..2a2b08089726
--- /dev/null
+++ b/dev-perl/Filesys-SmbClient/files/Filesys-SmbClient-3.200.0-pkg_config.patch
@@ -0,0 +1,36 @@
+From fa320a06147079458aa5f4834ae8b22cfe278481 Mon Sep 17 00:00:00 2001
+From: Dennis Lichtenthaeler <dennis.lichtenthaeler@stiftung-tannenhof.de>
+Date: Wed, 27 Apr 2016 10:57:17 +0200
+Subject: [PATCH 3/3] Use pkg-config instead of trickery to find samba-4
+ libs/headers
+
+---
+ Makefile.PL | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 954df92..ed9d846 100755
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -110,6 +110,18 @@ sub find_path {
+ push(@path, $_."/$ext") if !$defaultsDir->{$_};
+ }
+ foreach (keys %$defaultsDir) { push(@path, $_."/$ext"); }
++
++ ## get default paths from pkg-config
++ my $pkgconfig;
++ if($_[0]=~m!\.h$!) {
++ $pkgconfig = qx/pkg-config --variable=includedir smbclient/;
++ }
++ else {
++ $pkgconfig = qx/pkg-config --variable=libdir smbclient/;
++ }
++ $pkgconfig =~ s/\n//g;
++ push(@path, $pkgconfig);
++
+ print "I search in: ",(join "\n", @path),"\n";
+ return @path;
+ }
+--
+2.7.3
+