summaryrefslogtreecommitdiff
path: root/dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
commit2e34d110f164bf74d55fced27fe0000201b3eec5 (patch)
treef00ae60197c58f84ad51f60b210738d9b70f555b /dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild
parentf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (diff)
gentoo resync : 01.10.2020
Diffstat (limited to 'dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild')
-rw-r--r--dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild b/dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild
new file mode 100644
index 000000000000..8f1d9c6227ff
--- /dev/null
+++ b/dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CBARRATT
+DIST_VERSION=0.76
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="An rsync perl module"
+HOMEPAGE="http://perlrsync.sourceforge.net/ https://metacpan.org/release/File-RsyncP"
+# Bundled files make for some weirdness
+LICENSE="GPL-3+ GPL-2+ RSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Getopt-Long-2.240.0
+ net-misc/rsync
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.700.0-make.patch" )
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}