summaryrefslogtreecommitdiff
path: root/dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-21 11:40:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-21 11:40:40 +0000
commitbae478b64a6bc9eca66b65bcfa318fc21e7f34bb (patch)
treef713006fd9c119e5dbb3bdafe7d695d2644da94c /dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild
parent374561aeaff53ce5a2836af934749923b4ea3763 (diff)
gentoo auto-resync : 21:01:2023 - 11:40:40
Diffstat (limited to 'dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild')
-rw-r--r--dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild b/dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild
new file mode 100644
index 000000000000..2c19a775d327
--- /dev/null
+++ b/dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CBARRATT
+DIST_VERSION=0.76
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="An rsync perl module"
+HOMEPAGE="http://perlrsync.sourceforge.net/ https://metacpan.org/release/File-RsyncP"
+# Bundled files make for some weirdness
+LICENSE="GPL-3+ GPL-2+ RSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Getopt-Long-2.240.0
+ net-misc/rsync
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.700.0-make.patch"
+ "${FILESDIR}/${PN}-0.760.0-lto.patch"
+ "${FILESDIR}/${PN}-0.760.0-clang16.patch"
+)
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}