summaryrefslogtreecommitdiff
path: root/dev-perl/File-Next/File-Next-1.180.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-perl/File-Next/File-Next-1.180.0-r1.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-perl/File-Next/File-Next-1.180.0-r1.ebuild')
-rw-r--r--dev-perl/File-Next/File-Next-1.180.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/File-Next/File-Next-1.180.0-r1.ebuild b/dev-perl/File-Next/File-Next-1.180.0-r1.ebuild
new file mode 100644
index 000000000000..78b02898668e
--- /dev/null
+++ b/dev-perl/File-Next/File-Next-1.180.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.18
+inherit perl-module
+
+DESCRIPTION="An iterator-based module for finding files"
+
+LICENSE="Artistic-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/perl-File-Spec"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-File-Temp-0.220.0
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+src_test() {
+ # Ugh, Upstream has tests that depend on tests ...
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod.t"
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod-coverage.t"
+ perl-module_src_test
+}