summaryrefslogtreecommitdiff
path: root/dev-perl/ExtUtils-XSpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/ExtUtils-XSpp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/ExtUtils-XSpp')
-rw-r--r--dev-perl/ExtUtils-XSpp/ExtUtils-XSpp-0.180.0.ebuild28
-rw-r--r--dev-perl/ExtUtils-XSpp/Manifest4
-rw-r--r--dev-perl/ExtUtils-XSpp/files/ExtUtils-XSpp-0.180.0-no-dot-inc.patch344
-rw-r--r--dev-perl/ExtUtils-XSpp/metadata.xml47
4 files changed, 423 insertions, 0 deletions
diff --git a/dev-perl/ExtUtils-XSpp/ExtUtils-XSpp-0.180.0.ebuild b/dev-perl/ExtUtils-XSpp/ExtUtils-XSpp-0.180.0.ebuild
new file mode 100644
index 000000000000..730c1130cb27
--- /dev/null
+++ b/dev-perl/ExtUtils-XSpp/ExtUtils-XSpp-0.180.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=SMUELLER
+MODULE_VERSION=0.18
+inherit perl-module
+
+DESCRIPTION="XS for C++"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Digest-MD5-2.0.0
+ >=virtual/perl-ExtUtils-ParseXS-3.70.0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+ test? (
+ dev-perl/Test-Differences
+ dev-perl/Test-Base
+ )
+"
+PATCHES=( "${FILESDIR}/${P}-no-dot-inc.patch" )
+SRC_TEST="do parallel"
diff --git a/dev-perl/ExtUtils-XSpp/Manifest b/dev-perl/ExtUtils-XSpp/Manifest
new file mode 100644
index 000000000000..4bc366001a60
--- /dev/null
+++ b/dev-perl/ExtUtils-XSpp/Manifest
@@ -0,0 +1,4 @@
+AUX ExtUtils-XSpp-0.180.0-no-dot-inc.patch 7820 BLAKE2B 3a4418b6160b992b542a3db0fbcee598579d126273626968e2877ae6f3ffcc88fb86554f3adcf91c96034dfb6597f5f1f3eef0e4fcb7015a084d40c9e8bb3b4b SHA512 52c4fa509e7eb7d3a7320094c9818b4152ae833fe4b24a04402ede6a091a524f2f623cc12bb03a5e94a938ca5110b75ee828130eaa701334763636ace34f10b5
+DIST ExtUtils-XSpp-0.18.tar.gz 185431 BLAKE2B 785bc3fc8e648bc7f079df0d6b0ca68cc156d1f661b49258c32ae1d5571c2715a97f3dedd34e54c48cac85c46fcedf95ce78cc69444396502527b29b9f8e7d6e SHA512 0e075876f8a269bd0df71a37bcfe7c164fa18ffabe72deecb57d5ebefa3a78fc0c2438e75319497e0e1f99e6f9af9ae33af8ecb67e1d411356d6f3a50cd9ea1e
+EBUILD ExtUtils-XSpp-0.180.0.ebuild 520 BLAKE2B d870da30ab8feb81a833c40737e872f0d29954ca11dc15d9efe3f145959dfa046d3b51359e94d53805657aca1260ef1d1d3227a6a9f76ec87c4e9fd5ff9c1091 SHA512 12f42f3927ab156345f70d1d2fa6ebea6accfd7d39da7181bbba1c3252d8b48fdcae4ce190e4078512bac6c330fe28cd7762af88dbf4afa6b410e62c32e51407
+MISC metadata.xml 3043 BLAKE2B 73a8a9b2ef14dba26f5480b362136002cd010697f09fba5c3188bc604f4759e4da322c404eeb497ff3c5a7421900fe7750d2f8d1296b44c1f68ea2b8ac326099 SHA512 5a0172d4d3bfe0fe174fd690ff796f589350b2ee91f93d72a23d90f128cb48434bec712bda6c3619b205b0ba980d1207c0116ecf9a6ae50963fe09f413ce4a00
diff --git a/dev-perl/ExtUtils-XSpp/files/ExtUtils-XSpp-0.180.0-no-dot-inc.patch b/dev-perl/ExtUtils-XSpp/files/ExtUtils-XSpp-0.180.0-no-dot-inc.patch
new file mode 100644
index 000000000000..1605f278b2d8
--- /dev/null
+++ b/dev-perl/ExtUtils-XSpp/files/ExtUtils-XSpp-0.180.0-no-dot-inc.patch
@@ -0,0 +1,344 @@
+From 6875b61003a7a5e3d4c96ad12d74a02433baf9d7 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 21 Oct 2017 11:04:37 +1300
+Subject: Fix test failures without '.' in @INC on 5.26+
+
+This fixes test failures when perl is running with PERL_USE_UNSAFE_INC=0
+set in the environment.
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=121070
+Bug: https://bugs.gentoo.org/615240
+Bug: https://github.com/mbarbon/extutils-xspp/pull/3
+---
+ t/010_base.t | 3 ++-
+ t/011_multiple_files.t | 3 ++-
+ t/012_preprocessor.t | 3 ++-
+ t/013_typemap_output.t | 3 ++-
+ t/015_reference.t | 3 ++-
+ t/020_rename.t | 3 ++-
+ t/022_static.t | 3 ++-
+ t/022_virtual.t | 3 ++-
+ t/023_base_classes.t | 3 ++-
+ t/024_enum.t | 3 ++-
+ t/025_member.t | 3 ++-
+ t/030_code_blocks.t | 3 ++-
+ t/031_verbatim_blocks.t | 3 ++-
+ t/035_include.t | 3 ++-
+ t/040_plugin.t | 7 ++++---
+ t/043_parser_plugins.t | 3 ++-
+ t/075_types.t | 3 ++-
+ t/080_complex_typemap.t | 3 ++-
+ t/090_exceptions.t | 3 ++-
+ t/lib/XSP/Plugin.pm | 2 +-
+ t/lib/XSP/Test.pm | 4 ++--
+ 21 files changed, 43 insertions(+), 24 deletions(-)
+
+diff --git a/t/010_base.t b/t/010_base.t
+index 893857a..1c36dce 100644
+--- a/t/010_base.t
++++ b/t/010_base.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 14;
++use lib 't/lib';
++use XSP::Test tests => 14;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/011_multiple_files.t b/t/011_multiple_files.t
+index addf386..e4df4a5 100644
+--- a/t/011_multiple_files.t
++++ b/t/011_multiple_files.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 3;
++use lib 't/lib';
++use XSP::Test tests => 3;
+
+ run_diff process => 'expected';
+
+diff --git a/t/012_preprocessor.t b/t/012_preprocessor.t
+index 44e41a7..9a73626 100644
+--- a/t/012_preprocessor.t
++++ b/t/012_preprocessor.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 6;
++use lib 't/lib';
++use XSP::Test tests => 6;
+
+ # monkeypatch print methods to test conditionals are parsed correctly
+ no warnings 'redefine';
+diff --git a/t/013_typemap_output.t b/t/013_typemap_output.t
+index 6ed48bb..fb38f4a 100644
+--- a/t/013_typemap_output.t
++++ b/t/013_typemap_output.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 5;
++use lib 't/lib';
++use XSP::Test tests => 5;
+
+ use ExtUtils::XSpp;
+ use ExtUtils::XSpp::Typemap::simple;
+diff --git a/t/015_reference.t b/t/015_reference.t
+index e3ade61..0728c16 100644
+--- a/t/015_reference.t
++++ b/t/015_reference.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 2;
++use lib 't/lib';
++use XSP::Test tests => 2;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/020_rename.t b/t/020_rename.t
+index da55b07..7ecb125 100644
+--- a/t/020_rename.t
++++ b/t/020_rename.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 9;
++use lib 't/lib';
++use XSP::Test tests => 9;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/022_static.t b/t/022_static.t
+index 857ca30..24c13ed 100644
+--- a/t/022_static.t
++++ b/t/022_static.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 1;
++use lib 't/lib';
++use XSP::Test tests => 1;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/022_virtual.t b/t/022_virtual.t
+index b8d3a65..1dfdb3d 100644
+--- a/t/022_virtual.t
++++ b/t/022_virtual.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 3;
++use lib 't/lib';
++use XSP::Test tests => 3;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/023_base_classes.t b/t/023_base_classes.t
+index 52b01be..a25aeb7 100644
+--- a/t/023_base_classes.t
++++ b/t/023_base_classes.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 2;
++use lib 't/lib';
++use XSP::Test tests => 2;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/024_enum.t b/t/024_enum.t
+index 536d661..53c1774 100644
+--- a/t/024_enum.t
++++ b/t/024_enum.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 2;
++use lib 't/lib';
++use XSP::Test tests => 2;
+
+ # monkeypatch Enum/EnumValue just to test that they were parsed correctly
+ no warnings 'redefine';
+diff --git a/t/025_member.t b/t/025_member.t
+index c7f4fdc..ba1d8a3 100644
+--- a/t/025_member.t
++++ b/t/025_member.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 4;
++use lib 't/lib';
++use XSP::Test tests => 4;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/030_code_blocks.t b/t/030_code_blocks.t
+index 56cc97e..1f2f873 100644
+--- a/t/030_code_blocks.t
++++ b/t/030_code_blocks.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 6;
++use lib 't/lib';
++use XSP::Test tests => 6;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/031_verbatim_blocks.t b/t/031_verbatim_blocks.t
+index 68b66a7..1f3b6a7 100644
+--- a/t/031_verbatim_blocks.t
++++ b/t/031_verbatim_blocks.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 2;
++use lib 't/lib';
++use XSP::Test tests => 2;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/035_include.t b/t/035_include.t
+index b52a25d..66de3e0 100644
+--- a/t/035_include.t
++++ b/t/035_include.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 1;
++use lib 't/lib';
++use XSP::Test tests => 1;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/040_plugin.t b/t/040_plugin.t
+index dc3d975..680eda1 100644
+--- a/t/040_plugin.t
++++ b/t/040_plugin.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 2;
++use lib 't/lib';
++use XSP::Test tests => 2;
+
+ run_diff xsp_stdout => 'expected';
+
+@@ -12,8 +13,8 @@ __DATA__
+ --- xsp_stdout
+ %module{Foo};
+ %package{Foo};
+-%loadplugin{t::lib::XSP::Plugin};
+-%loadplugin{t::lib::XSP::Plugin};
++%loadplugin{XSP::Plugin};
++%loadplugin{XSP::Plugin};
+
+ int foo(int y);
+
+diff --git a/t/043_parser_plugins.t b/t/043_parser_plugins.t
+index 5d2a56e..9c11b1b 100644
+--- a/t/043_parser_plugins.t
++++ b/t/043_parser_plugins.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 4;
++use lib 't/lib';
++use XSP::Test tests => 4;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/075_types.t b/t/075_types.t
+index 7616be2..b31de8d 100644
+--- a/t/075_types.t
++++ b/t/075_types.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 5;
++use lib 't/lib';
++use XSP::Test tests => 5;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/080_complex_typemap.t b/t/080_complex_typemap.t
+index 560f502..5e7c84b 100644
+--- a/t/080_complex_typemap.t
++++ b/t/080_complex_typemap.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 6;
++use lib 't/lib';
++use XSP::Test tests => 6;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/090_exceptions.t b/t/090_exceptions.t
+index 0ad4f94..8043f61 100644
+--- a/t/090_exceptions.t
++++ b/t/090_exceptions.t
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-use t::lib::XSP::Test tests => 9;
++use lib 't/lib';
++use XSP::Test tests => 9;
+
+ run_diff xsp_stdout => 'expected';
+
+diff --git a/t/lib/XSP/Plugin.pm b/t/lib/XSP/Plugin.pm
+index 8f0cd2a..e4b2212 100644
+--- a/t/lib/XSP/Plugin.pm
++++ b/t/lib/XSP/Plugin.pm
+@@ -1,4 +1,4 @@
+-package t::lib::XSP::Plugin;
++package XSP::Plugin;
+
+ use strict;
+ use warnings;
+diff --git a/t/lib/XSP/Test.pm b/t/lib/XSP/Test.pm
+index 4bd7000..1d9f4bb 100644
+--- a/t/lib/XSP/Test.pm
++++ b/t/lib/XSP/Test.pm
+@@ -1,4 +1,4 @@
+-package t::lib::XSP::Test;
++package XSP::Test;
+
+ use strict;
+ use warnings;
+@@ -39,7 +39,7 @@ sub run_diff(@) {
+
+ use ExtUtils::XSpp;
+
+-package t::lib::XSP::Test::Filter;
++package XSP::Test::Filter;
+
+ use Test::Base::Filter -base;
+
+--
+2.14.2
+
diff --git a/dev-perl/ExtUtils-XSpp/metadata.xml b/dev-perl/ExtUtils-XSpp/metadata.xml
new file mode 100644
index 000000000000..945424a3341c
--- /dev/null
+++ b/dev-perl/ExtUtils-XSpp/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">ExtUtils-XSpp</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Cmd</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Driver</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Exception</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Exception::code</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Exception::object</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Exception::perlcode</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Exception::simple</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Exception::stdmessage</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Exception::unknown</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Grammar</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Grammar::YappDriver</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Lexer</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Access</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Argument</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Class</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Comment</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Constructor</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Destructor</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Enum</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::EnumValue</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::File</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Function</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Method</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Module</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Package</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::PercAny</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Preprocessor</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Raw</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Node::Type</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Parser</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Typemap</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Typemap::parsed</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Typemap::reference</remote-id>
+ <remote-id type="cpan-module">ExtUtils::XSpp::Typemap::simple</remote-id>
+ </upstream>
+</pkgmetadata>